Jetspeed 2
  1. Jetspeed 2
  2. JS2-1069

Portal Site should not filter folders w/o pages when page exists within menu depth constraints

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1.3, 2.2.1
    • Fix Version/s: 2.1.4, 2.2.1
    • Labels:
      None
    • Environment:
      Pull down/deep declarative menus

      Description

      Problem causes pages below empty folders to be inaccessible to pull down menus incorrectly. Other menu filtering should be reviewed for this use case.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        165d 35m 1 Randy Watler 09/Mar/10 19:53
        Resolved Resolved Closed Closed
        574d 1h 10m 1 Ate Douma 04/Oct/11 22:04
        Ate Douma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Randy Watler made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Randy Watler added a comment -

        Cannot reproduce in current 2.1.4 and 2.2.1 release code bases.

        Commits for verifying test cases:

        2.2.1: 921082 - JS2-1069: verified portal site does not filter folder menus without pages
        2.1.4: 921083 - JS2-1069: verified portal site does not filter folder menus without pages

        Randy Watler made changes -
        Field Original Value New Value
        Description Problem causes pages below empty folders to be inaccessible to pull down menus incorrectly. Other menu filtering should be review for this use case. Problem causes pages below empty folders to be inaccessible to pull down menus incorrectly. Other menu filtering should be reviewed for this use case.
        Randy Watler created issue -

          People

          • Assignee:
            Randy Watler
            Reporter:
            Randy Watler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development