Jetspeed 2
  1. Jetspeed 2
  2. JS2-1064

Jetspeed Maven Plugin errors with Maven 2.1.x or Maven 2.2.x

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.1
    • Component/s: None
    • Labels:
      None

      Description

      If I build Jetspeed-2.2.x with maven 2.1.x or maven 2.2.x with "-e" command line option (after 'mvn -P init clean install'), then I meet the following errors:

      <SNIP>
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Jetspeed-2 RDBMS Components
      [INFO] task-segment: [clean, install]
      [INFO] ------------------------------------------------------------------------
      [INFO] [clean:clean

      {execution: default-clean}

      ]
      [INFO] Deleting file set: .../jetspeed-2-TRUNK/components/jetspeed-rdbms/target (included: [**], excluded: [])
      [INFO] Deleting file set: .../jetspeed-2-TRUNK/components/jetspeed-rdbms (included: [*.log], excluded: [])
      [INFO] [assembly:single

      {execution: make-project-assembly-source-release}

      ]
      [INFO] Assemblies have been skipped per configuration of the skipAssembly parameter.
      [INFO] [remote-resources:process

      {execution: default}

      ]
      [INFO] [resources:resources

      {execution: default-resources}

      ]
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] skip non existing resourceDirectory .../jetspeed-2-TRUNK/components/jetspeed-rdbms/src/main/resources
      [INFO] Copying 0 resource
      [INFO] Copying 3 resources
      [INFO] [compiler:compile

      {execution: default-compile}

      ]
      [INFO] Compiling 18 source files to.../jetspeed-2-TRUNK/components/jetspeed-rdbms/target/classes
      [INFO] [resources:testResources

      {execution: default-testResources}

      ]
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] skip non existing resourceDirectory .../jetspeed-2-TRUNK/components/jetspeed-rdbms/src/test/resources
      [INFO] Copying 1 resource
      [INFO] Copying 3 resources
      [INFO] [jetspeed-unpack:unpack

      {execution: unpack-test-resources}

      ]
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Either specify artifact or file
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: Either specify artifact or file
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Either specify artifact or file
      at org.apache.jetspeed.maven.utils.UnpackResources.unpack(UnpackResources.java:341)
      at org.apache.jetspeed.maven.plugins.UnpackMojo.execute(UnpackMojo.java:81)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      ... 17 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 52 seconds
      [INFO] Finished at: Fri Sep 18 10:15:06 CEST 2009
      [INFO] Final Memory: 64M/223M

      It seems that there's some issues with the jetspeed unpack plugin with newer mavens.

        Activity

        Ate Douma added a comment -

        I Adjusted the build configuration for Maven 2.2.x (and probably Maven 2.1.x) changed plugin dependencies inheritance (not!).
        The "default" jetspeed-maven-unpack-plugin dependency is no longer "seen" from a parent pom
        However, once a child pom does "load" such a dependency, sibling poms suddenly start "seeing" it again...
        Sigh, seems like a maven bug which we somehow have to workaround.
        Solved for now by defining the needed "default" jetspeed-portal-resources dependency in each plugin usage.
        Additionally, while in there I also improved the <skip/> property configuration by replacing its value from $

        {maven.test.skip}

        to

        {skipTests}

        Finally, I also source formatted (again) some of the poms, but no changes other than described above were made.

        This fixes the build with Maven 2.2.1, I skipped (testing) Maven 2.1.x


          People

          • Assignee:
            Ate Douma
            Reporter:
            Woonsan Ko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development