Jetspeed 2
  1. Jetspeed 2
  2. JS2-1044

Folder document order removed on page update

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2.2.1
    • Component/s: PSML
    • Labels:
      None

      Description

      When editing a page from Portal Site Manager removes the Document Order.

      Looking at the code, it looks like AbstractPageManager.java
      updateDocumentOrder() is called everytime the page is updated and if the
      page is already there in the document order list of the folder, its removed.

      documentOrder.remove(name);

      Change the above code to the following fixed the issue.
      if ( !this.folderExists( name )

      { documentOrder.remove() }

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        246d 3h 5m 1 Randy Watler 19/Mar/10 06:17
        Resolved Resolved Closed Closed
        564d 14h 47m 1 Ate Douma 04/Oct/11 22:04
        Ate Douma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Randy Watler made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Randy Watler added a comment -

        Editing pages or folders in the Portal Site Manager does not seem to effect the parent folder document order.

        The code snippet mentioned in the bug report no longer exists in either Jetspeed or J2-admin, so it is likely that it has been replaced by code in the actions and/or services layer. Furthermore, it is unlikely that AbstractPageManager has ever played a role in page updates.

        If this can be reproduced with a more concrete set of instructions on 2.2.0 or 2.2.1-SNAPSHOT, we can reopen this issue.

        Randy Watler made changes -
        Field Original Value New Value
        Fix Version/s 2.2.1 [ 12313443 ]
        Affects Version/s 2.2.0 [ 12312318 ]
        Randy Watler created issue -

          People

          • Assignee:
            Randy Watler
            Reporter:
            Randy Watler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development