Jetspeed 2
  1. Jetspeed 2
  2. JS2-1012

Event Demo not working correctly on Desktop

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Component/s: Desktop
    • Labels:
      None

      Description

      The Event Demo demonstrates the Portlet 2.0 Event features. It works on /portal, but doesn't work on /desktop. The event is received but doesn't get updated in doView until subsequent doView cycles. I think we need to build in an event cycle into the /desktop. To reproduce:

      1. navigate to http://localhost:8080/jetspeed/desktop/Public/map.psml, you should see the default Map, San Francisco
      2. enter "Detroit" (or any address will do)
      3. the page still displays SF
      4. refresh, or maximize, the correct Detroit map now displays

        Activity

        Ate Douma made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Woonsan Ko made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Woonsan Ko added a comment -

        This problem has been fixed by APA-14.

        David Sean Taylor added a comment -

        Turns out events are working fine. Render parameters set from an event are not being picked up on the next render request. However, subsequent render requests (next render request + 1) do pick up the render parameters

        response.setRenderParameter("address", payload.getAddress());

        David Sean Taylor made changes -
        Field Original Value New Value
        Status Open [ 1 ] In Progress [ 3 ]
        David Sean Taylor created issue -

          People

          • Assignee:
            David Sean Taylor
            Reporter:
            David Sean Taylor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development