Uploaded image for project: 'Apache Jena'
  1. Apache Jena
  2. JENA-1480

Bad Request 400 returned when clicking "count triples in all graphs" in Fuseki info

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Jena 3.7.0
    • Fix Version/s: Jena 3.7.0
    • Component/s: Fuseki
    • Labels:
      None

      Description

      When I click "count triples in all graphs", the UI doesn't change and I see the following in the Chrome console:

      GET <FUSEKI_URL>/query?query=select%20(count(*)%20as%20?count)%20\{?s%20?p%20?o}
      400 (Bad Request)
      jquery-1.10.2.min.js:6
      

      I've experienced this in Fuseki 2.6.0 when using the WAR too. I'm also using the "tdb:unionDefaultGraph true" configuration setting.

      I've used someone else's install of Fuseki 2.5.0 and it works for them. I don't think they're using "tdb:unionDefaultGraph true", and I'm not sure if they're using the WAR or a standalone. Since there is no Server: Apache-Coyote response header, I'm guessing they're using the standalone. I don't know if that would make a difference. 

       

        Attachments

        1. error.html
          6 kB
          David Cook

          Issue Links

            Activity

              People

              • Assignee:
                andy Andy Seaborne
                Reporter:
                dcook David Cook
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: