Uploaded image for project: 'jclouds'
  1. jclouds
  2. JCLOUDS-554

openstack-nova defaults to API v1.1

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.8.0
    • Component/s: jclouds-compute
    • Labels:

      Description

      All of the domain objects in openstack-nova are written for v2 of the API (org.jclouds.openstack.nova.v2_0.*) but jclouds talks to v1.1 endpoints by default.

      Also v1.1 hasn't been used in OpenStack since Diablo, 5 releases ago. Diablo isn't even supported anymore.

      openstack-nova should default to v2 in the pom.xml test.openstack-nova.api-version and in NovaApiMetadata.

      HP might still be running v1.1 on their Diablo based "pre-13.5" HPCloud which is to be discontinued on June 1, 2014.

        Attachments

          Activity

            People

            • Assignee:
              jdaggett Jeremy Daggett
              Reporter:
              everett-toews Everett Toews
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: