James Server
  1. James Server
  2. JAMES-990

Exception at first start for JDBCDomainList Configuration

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 3.0-M1
    • Labels:
      None

      Description

      Build and deploy current trunk.

      Configuration scenario 1:
      ---------------------------------

      • James.xml:
        <enableVirtualHosting> true </enableVirtualHosting>
      • domainlist.xml :
        <!-- comment this if you use JDBCDomainList -->
        <!--
        <domainnames>
        <domainname>localhost</domainname>
        </domainnames>
        -->
        <!-- uncomment this if you use JDBCDomainList -->
        <repositoryPath>db://maildb/domain</repositoryPath>
        <sqlFile>file://conf/sqlResources.xml</sqlFile>
      • springbeans.xml
        use the <bean id="domainlist" class="org.apache.james.domain.JDBCDomainList"/>
        and not the <bean id="domainlist" class="org.apache.james.domain.XMLDomainList"/>

      run.sh gives an exception
      Caused by: org.apache.commons.configuration.ConfigurationException: Configured defaultdomain could not get added to DomainList

      run.sh a second time, everything's ok

      Configuration scenario 2:
      -----------------------------------

      Same, but don't comment the domainnames in domainlist.xml
      run.sh gives the same exception

      run.sh a second time, everything's ok

      PS : By the way, with the embedded derby out-of-the-box, could the default config be enableVirtualHosting=true and JDBCDomainList.

      1. james-990.patch
        1 kB
        Eric Charles

        Activity

        Eric Charles added a comment -

        Attached james-990.patch solves the described issue.
        It also allows to take into account the defaultDomain defined in James.xml.

        Norman Maurer added a comment -

        Patch committed, thanks a bunch Eric!


          People

          • Assignee:
            Norman Maurer
            Reporter:
            Eric Charles
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development