James Server
  1. James Server
  2. JAMES-904

DB Connection problem: Reason in log: Component named "database-connections" failed to pass through the Starting stage.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 2.3.1
    • Fix Version/s: 3.0-M1
    • Component/s: James Core
    • Labels:
      None
    • Environment:
      Linux Centos 4.4, i386.

      Description

      Im trying to connect to an AS400 database and get the following error...

      ERROR 2009-05-11 13:02:01.063 [Phoenix.] (): Component named "database-connections" failed to pass through the Starting stage. (Reason: org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource).
      ERROR 2009-05-11 13:02:01.063 [Phoenix.] (): There was an error running phase "startup" for Block named "database-connections". (Reason: Component named "database-connections" failed to pass through the Starting stage. (Reason: org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource).).
      org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleException: Component named "database-connections" failed to pass through the Starting stage. (Reason: org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource).
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.fail(LifecycleHelper.java:354)
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.startup(LifecycleHelper.java:226)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.startup(DefaultApplication.java:530)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.doRunPhase(DefaultApplication.java:478)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.runPhase(DefaultApplication.java:409)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.start(DefaultApplication.java:180)
      at org.apache.avalon.framework.container.ContainerUtil.start(ContainerUtil.java:260)
      rethrown from
      org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource
      at org.apache.james.util.dbcp.JdbcDataSource.configure(JdbcDataSource.java:200)
      at org.apache.avalon.cornerstone.blocks.datasources.DefaultDataSourceSelector.initialize(DefaultDataSourceSelector.java:147)
      at org.apache.avalon.framework.container.ContainerUtil.initialize(ContainerUtil.java:244)
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.startup(LifecycleHelper.java:200)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.startup(DefaultApplication.java:530)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.doRunPhase(DefaultApplication.java:478)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.runPhase(DefaultApplication.java:409)
      rethrown from
      org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (The application requester cannot establish the connection. (Connection timed out))
      at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:855)
      at org.apache.james.util.dbcp.JdbcDataSource$1.createDataSource(JdbcDataSource.java:113)
      at org.apache.commons.dbcp.BasicDataSource.setLogWriter(BasicDataSource.java:598)
      at org.apache.james.util.dbcp.JdbcDataSource.configure(JdbcDataSource.java:157)
      at org.apache.avalon.cornerstone.blocks.datasources.DefaultDataSourceSelector.initialize(DefaultDataSourceSelector.java:147)
      at org.apache.avalon.framework.container.ContainerUtil.initialize(ContainerUtil.java:244)
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.startup(LifecycleHelper.java:200)
      rethrown from
      java.sql.SQLNonTransientConnectionException: The application requester cannot establish the connection. (Connection timed out)
      at com.ibm.as400.access.JDError.createSQLExceptionSubClass(JDError.java:760)
      at com.ibm.as400.access.JDError.throwSQLException(JDError.java:541)
      at com.ibm.as400.access.AS400JDBCConnection.setProperties(AS400JDBCConnection.java:3037)
      at com.ibm.as400.access.AS400JDBCDriver.prepareConnection(AS400JDBCDriver.java:1254)
      at com.ibm.as400.access.AS400JDBCDriver.initializeConnection(AS400JDBCDriver.java:1105)
      at com.ibm.as400.access.AS400JDBCDriver.connect(AS400JDBCDriver.java:355)
      at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:37)
      INFO 2009-05-11 13:02:01.075 [Phoenix.] (): exception while starting:Component named "database-connections" failed to pass through the Starting stage. (Reason: org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource).

      WARN 2009-05-11 13:02:01.080 [Phoenix.] (): Failed to start application james.
      org.apache.avalon.framework.CascadingException: Failed to start application james.
      at org.apache.avalon.phoenix.components.kernel.DefaultKernel.startup(DefaultKernel.java:313)
      at org.apache.avalon.phoenix.components.kernel.DefaultKernel.addApplication(DefaultKernel.java:376)
      at org.apache.avalon.phoenix.components.deployer.DefaultDeployer.deploy(DefaultDeployer.java:357)
      at org.apache.avalon.phoenix.components.embeddor.DefaultEmbeddor.deployFile(DefaultEmbeddor.java:542)
      at org.apache.avalon.phoenix.components.embeddor.DefaultEmbeddor.deployFile(DefaultEmbeddor.java:535)
      at org.apache.avalon.phoenix.components.embeddor.DefaultEmbeddor.deployFiles(DefaultEmbeddor.java:520)
      at org.apache.avalon.phoenix.components.embeddor.DefaultEmbeddor.deployDefaultApplications(DefaultEmbeddor.java:509)
      rethrown from
      org.apache.avalon.phoenix.interfaces.ApplicationException: Component named "database-connections" failed to pass through the Starting stage. (Reason: org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource).
      at org.apache.avalon.phoenix.components.application.DefaultApplication.start(DefaultApplication.java:186)
      at org.apache.avalon.framework.container.ContainerUtil.start(ContainerUtil.java:260)
      at org.apache.avalon.phoenix.components.kernel.DefaultKernel.startup(DefaultKernel.java:295)
      at org.apache.avalon.phoenix.components.kernel.DefaultKernel.addApplication(DefaultKernel.java:376)
      at org.apache.avalon.phoenix.components.deployer.DefaultDeployer.deploy(DefaultDeployer.java:357)
      at org.apache.avalon.phoenix.components.embeddor.DefaultEmbeddor.deployFile(DefaultEmbeddor.java:542)
      at org.apache.avalon.phoenix.components.embeddor.DefaultEmbeddor.deployFile(DefaultEmbeddor.java:535)
      rethrown from
      org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleException: Component named "database-connections" failed to pass through the Starting stage. (Reason: org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource).
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.fail(LifecycleHelper.java:354)
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.startup(LifecycleHelper.java:226)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.startup(DefaultApplication.java:530)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.doRunPhase(DefaultApplication.java:478)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.runPhase(DefaultApplication.java:409)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.start(DefaultApplication.java:180)
      at org.apache.avalon.framework.container.ContainerUtil.start(ContainerUtil.java:260)
      rethrown from
      org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource
      at org.apache.james.util.dbcp.JdbcDataSource.configure(JdbcDataSource.java:200)
      at org.apache.avalon.cornerstone.blocks.datasources.DefaultDataSourceSelector.initialize(DefaultDataSourceSelector.java:147)
      at org.apache.avalon.framework.container.ContainerUtil.initialize(ContainerUtil.java:244)
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.startup(LifecycleHelper.java:200)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.startup(DefaultApplication.java:530)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.doRunPhase(DefaultApplication.java:478)
      at org.apache.avalon.phoenix.components.application.DefaultApplication.runPhase(DefaultApplication.java:409)
      rethrown from
      org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (The application requester cannot establish the connection. (Connection timed out))
      at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:855)
      at org.apache.james.util.dbcp.JdbcDataSource$1.createDataSource(JdbcDataSource.java:113)
      at org.apache.commons.dbcp.BasicDataSource.setLogWriter(BasicDataSource.java:598)
      at org.apache.james.util.dbcp.JdbcDataSource.configure(JdbcDataSource.java:157)
      at org.apache.avalon.cornerstone.blocks.datasources.DefaultDataSourceSelector.initialize(DefaultDataSourceSelector.java:147)
      at org.apache.avalon.framework.container.ContainerUtil.initialize(ContainerUtil.java:244)
      at org.apache.avalon.phoenix.containerkit.lifecycle.LifecycleHelper.startup(LifecycleHelper.java:200)
      rethrown from
      java.sql.SQLNonTransientConnectionException: The application requester cannot establish the connection. (Connection timed out)
      at com.ibm.as400.access.JDError.createSQLExceptionSubClass(JDError.java:760)
      at com.ibm.as400.access.JDError.throwSQLException(JDError.java:541)
      at com.ibm.as400.access.AS400JDBCConnection.setProperties(AS400JDBCConnection.java:3037)
      at com.ibm.as400.access.AS400JDBCDriver.prepareConnection(AS400JDBCDriver.java:1254)
      at com.ibm.as400.access.AS400JDBCDriver.initializeConnection(AS400JDBCDriver.java:1105)
      at com.ibm.as400.access.AS400JDBCDriver.connect(AS400JDBCDriver.java:355)
      at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:37)
      WARN 2009-05-11 13:02:01.096 [Phoenix.] (): Failed to stop application james as it is not initialized/started.

        Activity

        Stefano Bagnara added a comment -

        I think AS400 has never been tested with james and for sure is not supported.

        It seems your jdbc driver is not able to connect to your as400. First you should fix this (a configuration issue on your side):
        java.sql.SQLNonTransientConnectionException: The application requester cannot establish the connection. (Connection timed out)
        at com.ibm.as400.access.JDError.createSQLExceptionSubClass(JDError.java:760)
        at com.ibm.as400.access.JDError.throwSQLException(JDError.java:541)
        at com.ibm.as400.access.AS400JDBCConnection.setProperties(AS400JDBCConnection.java:3037)
        at com.ibm.as400.access.AS400JDBCDriver.prepareConnection(AS400JDBCDriver.java:1254)
        at com.ibm.as400.access.AS400JDBCDriver.initializeConnection(AS400JDBCDriver.java:1105)
        at com.ibm.as400.access.AS400JDBCDriver.connect(AS400JDBCDriver.java:355)
        at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:37)
        INFO 2009-05-11 13:02:01.075 [Phoenix.] (): exception while starting:Component named "database-connections" failed to pass through the Starting stage. (Reason: org.apache.avalon.framework.configuration.ConfigurationException: Error configurable datasource).

        Norman Maurer added a comment -

        I think its save to close this because it seems more like a config error

        Aaron X Hertz added a comment -

        I encountered this issue as well.
        its root cause is not configuration, rather it is the oracle jdbc which i am using.

        ojdbc_6-g.jar (with debugging info) did not work with james 2.3.2.
        if you replace it with ojdbc6.jar, JAMES will run correctly.


          People

          • Assignee:
            Unassigned
            Reporter:
            DChenome
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development