James Server
  1. James Server
  2. JAMES-877

cannot start spring-deployment nightly build as described in provided batch file

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 3.0-M1
    • Component/s: None
    • Labels:
      None

      Description

      • spring-deployment nightly build date 2008-09-28 03:35:42
      • Bean creation failed due to NoSuchMethodError (TorqueMailboxManager: method <init>()V not found)

      28. September 2008, 03:35:42
      [java] INFO 13:13:03,859 | org.apache.james.container.spring.beanfactory.JamesApplicationContext | Unable to locate ApplicationEventMulticaster with name'applicationEventMulticaster': using default [org.springframework.context.event.SimpleApplicationEventMulticaster@10da5eb]
      [java] log4j:WARN No appenders could be found for logger (maildb).
      [java] log4j:WARN Please initialize the log4j system properly.
      [java] Exception in thread "main" org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'James': Initialization of bean failed; nested exception is java.lang.RuntimeException: could not successfully run service method on component of type class org.apache.james.James
      [java] Caused by: java.lang.RuntimeException: could not successfully run service method on component of type class org.apache.james.James
      [java] at org.apache.james.container.spring.lifecycle.ServicePropagator.invokeLifecycleWorker(ServicePropagator.java:57)
      [java] at org.apache.james.container.spring.lifecycle.AbstractPropagator.postProcessAfterInitialization(AbstractPropagator.java:56)
      [java] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyBeanPostProcessorsAfterInitialization(AbstractAutowireCapableBeanFactory.java:311)
      [java] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1038)
      [java] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:420)
      [java] at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:245)
      [java] at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:141)
      [java] at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:242)
      [java] at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:156)
      [java] at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:290)
      [java] at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:348)
      [java] at org.apache.james.container.spring.beanfactory.JamesApplicationContext.newJamesApplicationContext(JamesApplicationContext.java:56)
      [java] at org.apache.james.container.spring.beanfactory.JamesApplicationContext.newJamesApplicationContext(JamesApplicationContext.java:49)
      [java] at org.apache.james.container.spring.beanfactory.JamesApplicationContext.newJamesApplicationContext(JamesApplicationContext.java:45)
      [java] at org.apache.james.container.spring.Main.main(Main.java:29)
      [java] Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'mailboxmanager': Initialization of bean failed; nested exception is java.lang.NoSuchMethodError: org.apache.james.mailboxmanager.torque.TorqueMailboxManager: method <init>()V not found
      [java] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:442)
      [java] at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:245)
      [java] at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:141)
      [java] at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:242)
      [java] at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:156)
      [java] at org.springframework.context.support.AbstractApplicationContext.getBean(AbstractApplicationContext.java:642)
      [java] at org.apache.james.container.spring.adaptor.DefaultServiceManagerFactory$ServiceManagerBridge.populateServiceMap(DefaultServiceManagerFactory.java:72)
      [java] at org.apache.james.container.spring.adaptor.DefaultServiceManagerFactory$ServiceManagerBridge.<init>(DefaultServiceManagerFactory.java:48)
      [java] at org.apache.james.container.spring.adaptor.DefaultServiceManagerFactory.getInstanceFor(DefaultServiceManagerFactory.java:114)
      [java] at org.apache.james.container.spring.lifecycle.ServicePropagator.invokeLifecycleWorker(ServicePropagator.java:49)
      [java] ... 14 more
      [java] Caused by: java.lang.NoSuchMethodError: org.apache.james.mailboxmanager.torque.TorqueMailboxManager: method <init>()V not found
      [java] at org.apache.james.mailboxmanager.torque.TorqueMailboxManagerFactory.<init>(TorqueMailboxManagerFactory.java:55)
      [java] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      [java] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      [java] at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      [java] at java.lang.Class.newInstance0(Class.java:355)
      [java] at java.lang.Class.newInstance(Class.java:308)
      [java] at org.apache.james.mailboxmanager.impl.DefaultMailboxManagerProvider.getClassInstace(DefaultMailboxManagerProvider.java:69)
      [java] at org.apache.james.mailboxmanager.impl.DefaultMailboxManagerProvider.configure(DefaultMailboxManagerProvider.java:55)
      [java] at org.apache.james.container.spring.lifecycle.ConfigurationPropagator.invokeLifecycleWorker(ConfigurationPropagator.java:65)
      [java] at org.apache.james.container.spring.lifecycle.AbstractPropagator.postProcessAfterInitialization(AbstractPropagator.java:56)
      [java] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyBeanPostProcessorsAfterInitialization(AbstractAutowireCapableBeanFactory.java:311)
      [java] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1038)
      [java] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:420)
      [java] ... 23 more
      [java] Java Result: 1

      1. build.xml
        0.4 kB
        Joerg Buchberger

        Activity

        Joerg Buchberger added a comment -

        Additional info:

        • since rev.689578 (2008-08-27) the default (no-argument-) constructor is missing from TorqueMailboxManagerFactory, which explains the NoSuchMethodError TorqueMailboxManager: method <init>()V from the stacktrace upon james-spring-deployment startup
        • org.apache.james.mailboxmanager.torque.TorqueMailboxManagerFactory has been deleted from trunk in rev.696024 on 2008-09-16
        • however, the nightly build from 2008-09-28 still ...
        • ... contains this class as part of apache-james-imap-torque-0.1-SNAPSHOT.jar
        • ... specifies this class as mailboxmanager factory in james-config.xml
        Robert Burrell Donkin added a comment -

        Please try again with new checkout and reopen if it's not fixed

        Joerg Buchberger added a comment -

        Thanks for fixing.
        Last nightly build (Oct 6) works for me too, if I use ant instead of the DOS batch file. (see attached build file)

        I verified orderly startup by accessing admin manager via telnet.


          People

          • Assignee:
            Unassigned
            Reporter:
            Joerg Buchberger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development