Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0-M1
    • Component/s: Deployment Modules
    • Labels:
      None

      Description

      A WAR file deployment on top of the spring-deployment.

        Activity

        Norman Maurer added a comment -

        Done..

        Norman Maurer added a comment -

        I think this should be really easy now.. Let me try todo it..

        Robert Burrell Donkin added a comment -

        AIUI these are phoenix container dependencies

        (I'm still a little hazy about the way that the Spring stuff works)

        Why are they needed for spring?

        Bernd Fondermann added a comment -

        ok, the full list of libs having issues with their extension declaration is:

        spice-configkit-1.1.2.jar
        spice-loggerstore-0.5.jar
        spice-classman-1.0.jar
        commons-attributes-compiler.jar
        spice-salt-0.8.jar

        Simply removing those declarations from all related Manifest.MFs helps.
        For the first three mentioned jars, upgrading helps, but AFAIK it is unknown if these newer releases work properly in the server.
        For the remaining two jars, upgrading has not yet been tried.

        The bad news is that another error appears which must still be investigated.

        Bernd Fondermann added a comment -

        Seems to be a problem with MANIFEST.MF again in commons-attributes-compiler.jar.
        I'm sure you know already... just edit the jars (they are actually zip files) or find a replacement like you did already.
        remove the malicious entries for a simple test and you might be the first man on earth booting james in a web container.
        "A small step for Tomcat, but a big step for mankind!"

        Jonas Arnsmann added a comment -

        Using the Latest Spice JAR's from http://dist.codehaus.org/spice/jars/ solves the problem with the Extension-List properties!
        The Working Libs are versioned:
        spice-classman-1.1.jar
        spice-configkit-1.2.jar
        spice-loggerstore-1.1.jar

        By looking at META-INF/MANIFEST.MF it looks like the newer version no longer use the comma seperated lists in the extension properties..

        However the James Spring Deployment still keeps failing..

        root@morpheus:/opt/apache-tomcat-6.0.18/bin# ./catalina.sh run
        Using CATALINA_BASE: /opt/apache-tomcat-6.0.18
        Using CATALINA_HOME: /opt/apache-tomcat-6.0.18
        Using CATALINA_TMPDIR: /opt/apache-tomcat-6.0.18/temp
        Using JRE_HOME: /usr/lib/jvm/java-1.5.0-sun
        16.02.2009 14:35:43 org.apache.catalina.core.AprLifecycleListener init
        INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-1.5.0-sun-1.5.0.16/jre/lib/i386/client:/usr/lib/jvm/java-1.5.0-sun-1.5.0.16/jre/lib/i386:/usr/lib/jvm/java-1.5.0-sun-1.5.0.16/jre/../lib/i386
        16.02.2009 14:35:43 org.apache.coyote.http11.Http11Protocol init
        INFO: Initializing Coyote HTTP/1.1 on http-8080
        16.02.2009 14:35:43 org.apache.catalina.startup.Catalina load
        INFO: Initialization processed in 693 ms
        16.02.2009 14:35:44 org.apache.catalina.core.StandardService start
        INFO: Starting service Catalina
        16.02.2009 14:35:44 org.apache.catalina.core.StandardEngine start
        INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
        16.02.2009 14:35:44 org.apache.catalina.startup.HostConfig deployWAR
        INFO: Deploying web application archive james-server-spring-deployment-3.0-SNAPSHOT.war
        16.02.2009 14:35:44 org.apache.catalina.util.ExtensionValidator validateManifestResources
        INFO: ExtensionValidator[/james-server-spring-deployment-3.0-SNAPSHOT][commons-attributes-compiler.jar]: Required extension "ant" not found.
        16.02.2009 14:35:44 org.apache.catalina.util.ExtensionValidator validateManifestResources
        INFO: ExtensionValidator[/james-server-spring-deployment-3.0-SNAPSHOT][commons-attributes-compiler.jar]: Required extension "qdox" not found.
        16.02.2009 14:35:44 org.apache.catalina.util.ExtensionValidator validateManifestResources
        INFO: ExtensionValidator[/james-server-spring-deployment-3.0-SNAPSHOT][commons-attributes-compiler.jar]: Required extension "commons-attributes-api" not found.
        16.02.2009 14:35:44 org.apache.catalina.util.ExtensionValidator validateManifestResources
        INFO: ExtensionValidator[/james-server-spring-deployment-3.0-SNAPSHOT][commons-attributes-compiler.jar]: Required extension "javadoc" not found.
        16.02.2009 14:35:44 org.apache.catalina.util.ExtensionValidator validateManifestResources
        INFO: ExtensionValidator[/james-server-spring-deployment-3.0-SNAPSHOT][spice-salt-0.8.jar]: Required extension "oro" not found.
        16.02.2009 14:35:44 org.apache.catalina.util.ExtensionValidator validateManifestResources
        INFO: ExtensionValidator[/james-server-spring-deployment-3.0-SNAPSHOT]: Failure to find 5 required extension(s).
        16.02.2009 14:35:44 org.apache.catalina.core.StandardContext start
        SCHWERWIEGEND: Error getConfigured
        16.02.2009 14:35:44 org.apache.catalina.core.StandardContext start
        SCHWERWIEGEND: Context [/james-server-spring-deployment-3.0-SNAPSHOT] startup failed due to previous errors
        16.02.2009 14:35:44 org.apache.catalina.core.StandardContext stop
        INFO: Container org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/james-server-spring-deployment-3.0-SNAPSHOT] has not been started
        16.02.2009 14:35:46 org.apache.coyote.http11.Http11Protocol start
        INFO: Starting Coyote HTTP/1.1 on http-8080
        16.02.2009 14:35:46 org.apache.jk.common.ChannelSocket init
        INFO: JK: ajp13 listening on /0.0.0.0:8009
        16.02.2009 14:35:46 org.apache.jk.server.JkMain start
        INFO: Jk running ID=0 time=0/35 config=null
        16.02.2009 14:35:46 org.apache.catalina.startup.Catalina start
        INFO: Server startup in 2459 ms

        Bernd Fondermann added a comment -

        These problems are caused by

        spice-configkit-1.1.2.jar
        spice-loggerstore-0.5.jar
        spice-classman-1.0.jar

        They have comma-separated values for the Exension-List property in their Manifest.MF

        Bernd Fondermann added a comment -

        There are currently 3 pitfalls related to a war deployment:

        1. resolve the extended james config files imported through xml entity definition in james-config.xml
        => I am trying to solve this by inlining them in the deployment
        2. Tomcat: there is something wrong with one of the lib manifests we are importing, see [1]
        => I am not quite clear what is happening there, but probably some lib's manifest is screwed up for Tomcat.
        3. Jetty: loads pretty well, but now it comes to create local files (derby, spooling, etc).
        => I will work on this.

        [1] from catalina.out:

        SEVERE: Error deploying web application archive james-server-spring-deployment-3.0-SNAPSHOT.war
        java.lang.IllegalArgumentException: oro,excalibur-i18n,excalibur-extension-Extension-Name
        at java.util.jar.Attributes$Name.<init>(Attributes.java:440)
        at java.util.jar.Attributes.getValue(Attributes.java:99)
        at org.apache.catalina.util.ManifestResource.getRequiredExtensions(ManifestResource.java:186)
        at org.apache.catalina.util.ManifestResource.processManifest(ManifestResource.java:155)
        at org.apache.catalina.util.ManifestResource.<init>(ManifestResource.java:52)
        at org.apache.catalina.util.ExtensionValidator.validateApplication(ExtensionValidator.java:186)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4064)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
        at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:825)
        at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:714)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:490)
        at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
        at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
        at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at org.apache.catalina.core.StandardService.start(StandardService.java:448)
        at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)


          People

          • Assignee:
            Norman Maurer
            Reporter:
            Bernd Fondermann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development