James Server
  1. James Server
  2. JAMES-787

Unable to resolv 127.0.0.1/localhost [was: Fetchmail not use 127.0.0.1 as RemoteAddress when using index=-1]

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.2.0, 2.3.0
    • Fix Version/s: 2.3.2
    • Component/s: FetchMail
    • Labels:
      None

      Description

      From ml:

      We tried to fetch emails via POP3 from a Exchange 2003 server which
      are sent from one local exchange account to an other local exchange
      account. Fetchmail stopped parsing the message because the ip is missing
      in the received header of the emails. Even if i use -1 as index the same
      happen. That seems to be a bug for me .. Should it not just use
      "127.0.0.1" and not try to parse it ? After adding a workarround which
      catch the UnknownHostexception and add "127.0.0.1" this is solved.

        Activity

        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12566868 ] jira [ 12581915 ]
        Mark Thomas made changes -
        Workflow jira [ 12402068 ] Default workflow, editable Closed status [ 12566868 ]
        Norman Maurer made changes -
        Resolution Won't Fix [ 2 ]
        Status Reopened [ 4 ] Resolved [ 5 ]
        Norman Maurer added a comment -

        I think this will not get fixed in 2.3.x ..

        Norman Maurer made changes -
        Attachment localResolv-2.3.diff [ 12357021 ]
        Norman Maurer added a comment -

        This is the diff for backporting to 2.3 branch . Any thoughts ?

        Norman Maurer made changes -
        Fix Version/s 2.3.1 [ 12312465 ]
        Summary Fetchmail not use 127.0.0.1 as RemoteAddress when using index=-1 Unable to resolv 127.0.0.1/localhost [was: Fetchmail not use 127.0.0.1 as RemoteAddress when using index=-1]
        Fix Version/s 2.3.2 [ 12312493 ]
        Norman Maurer made changes -
        Resolution Invalid [ 6 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Norman Maurer added a comment -

        Its seems to this is not invalid! The problem is that we fallback to 127.0.0.1/localhost and try to get sure we can resolv it. This is not possible with dnsjava. Maybe whould should add a config option to our dnsserver to specify a "hosts" file to parse and use . Any thoughts ?

        Norman Maurer made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Invalid [ 6 ]
        Norman Maurer added a comment -

        Invalid /etc/hosts file.

        Norman Maurer made changes -
        Fix Version/s 2.3.1 [ 12312465 ]
        Fix Version/s 2.3.1rc1 [ 12312150 ]
        Norman Maurer made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Norman Maurer added a comment -

        Reverted the patch.. Discussion in progress

        Norman Maurer made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Norman Maurer created issue -

          People

          • Assignee:
            Norman Maurer
            Reporter:
            Norman Maurer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development