James Server
  1. James Server
  2. JAMES-671

ServerConnection doesn't properly handle the TCP/IP backlog

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.0, 2.3.0
    • Fix Version/s: 2.3.1
    • Component/s: James Core
    • Labels:
      None

      Description

      ServerConnection calls accept() even when the configured connection limit has been reached, thereby purging the TCP/IP backlog and expending cycles in the process. This is inefficient, drops connections, and renders the backlog configuration setting largely worthless.

        Activity

        Stefano Bagnara added a comment -

        this is fixed in svn-trunk (next-major).
        The issue is still open because it could be backported to next-minor.

        Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            Noel J. Bergman
            Reporter:
            Noel J. Bergman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development