James Server
  1. James Server
  2. JAMES-62

Spooler loops and add message many times

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0a3
    • Fix Version/s: 2.2.0
    • Labels:
      None
    • Environment:
      Operating System: All
      Platform: All

      Description

      When posting the message below on a NT 4.0 System, the follwing happens:
      1) the file generated for message id is not valid on NT
      2) the spooler adds the message to the repository, but
      a) does not add the Message-ID
      b) does not delete the spool file
      and hence loops undefinitely;

      The Message-ID was taken from a real life newsgroup. I have not tested this
      on a Unix system.
      To reproduce, just place a file containg the message in the nntp/spool directory
      and start the server.

      Message-ID: <E5B80B001D76D211879C00E02910776104F807C1@njc240po05.mt.host.com>
      From: "Someuser" <someuser@host.com>
      Subject: Testing Long MessageIDs
      Date: Wed, 23 Aug 2000 15:43:48 -0400
      Newsgroups: org.apache.james.dev
      Path: news.host.com

      This is a valid message containing a long Message-ID

        Activity

        Serge Knystautas added a comment -

        Committed 10/20/2003 by Noel, included in 2.2.0a14.

        Noel J. Bergman added a comment -

        Simple fix in CVS that removes any CR or LF characters from the encoding. The
        encoding may still not be Windows-safe, since the file name is case sensitive.

        Peter M. Goldstein added a comment -

        This one is kind of silly. We should be using a file name safe encoding.
        Delaying until after 2.1 goes out - will need to include a "repository
        converter" to resolve this problem and support anyone using NNTP in 2.1.

        Christian Buchegger added a comment -

        found the root cause:
        the base64 encode from javax.mail.internet.MimeUtility adds line feeds to the
        encoded stream; this consequently leads to a IOException when the file for the
        repository id should be created.
        Finally due to this exception the code in NNTPSpooler$SpoolerRunnable.process()
        which deletes the spool file is skipped and will be picked up on the next loop
        again.


          People

          • Assignee:
            Unassigned
            Reporter:
            Christian Buchegger
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development