Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.3, 2.2.0, 2.3.0
    • Fix Version/s: 3.0-M1
    • Component/s: James Core, SMTPServer
    • Labels:
      None

      Description

      org.apache.james.util.NetMacher should be able to accept and match IPv6 network specifications to support relaying of mail that comes in over IPv6. This should add IPv6 support to the AuthorizedAdresses configuration and likely to most subclasses of AbstractNetworkMatcher as well.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        1764d 10h 36m 1 Eric Charles 13/Jun/10 17:36
        In Progress In Progress Open Open
        10s 1 Eric Charles 13/Jun/10 17:36
        Open Open Resolved Resolved
        7m 1s 1 Eric Charles 13/Jun/10 17:43
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12566528 ] jira [ 12582075 ]
        Mark Thomas made changes -
        Workflow jira [ 12323391 ] Default workflow, editable Closed status [ 12566528 ]
        Norman Maurer made changes -
        Fix Version/s 3.0-M1 [ 12314294 ]
        Fix Version/s Trunk [ 12312135 ]
        Eric Charles made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Eric Charles added a comment -

        IP v6 introduced with http://svn.apache.org/viewvc?rev=954226&view=rev
        Currently, the IP address must be completely specified (not shortened, as for example ::1) in the Matcher config.
        The patch is currently enough to further implement IPv6 support with JAMES-403 and JAMES-405.
        It is worth to come back later one to validate the complete James IPv6 support and to support the complete IPv6 syntax.
        Therefor, the issue is not closed.
        It is however of enough quality to support IPv6 matchers.

        Eric Charles made changes -
        Status In Progress [ 3 ] Open [ 1 ]
        Eric Charles made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Norman Maurer made changes -
        Assignee Eric Charles [ echarles ]
        Norman Maurer added a comment -

        Eric did the work for that..

        Stefano Bagnara made changes -
        Field Original Value New Value
        Fix Version/s Trunk [ 12312135 ]
        Fix Version/s Next Major [ 10427 ]
        Arjan Veenstra created issue -

          People

          • Assignee:
            Eric Charles
            Reporter:
            Arjan Veenstra
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development