Uploaded image for project: 'James Server'
  1. James Server
  2. JAMES-1041

Review each pom (in server and imap) for unused declared dependency and maven 3 compatibility

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Component/s: None
    • Labels:
      None

      Description

      If you run mvn dependency:analyze in pop3server for example, you will have:
      [WARNING] Unused declared dependencies found:
      [WARNING] org.apache.james:james-server-user-library:jar:3.0-SNAPSHOT:runtime
      [WARNING] org.apache.james:james-server-core-function:jar:3.0-SNAPSHOT:runtime

      Running pom with maven 3 also shows:
      [WARNING] The expression ${pom.version} is deprecated. Please use ${project.version} instead. @

      We must correct this for all server and imap projects (pom.xml).

        Attachments

        1. imap-poms-m3.patch
          11 kB
          Felix Knecht

          Activity

            People

            • Assignee:
              felixk Felix Knecht
              Reporter:
              eric@apache.org Eric Charles
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: