James Server
  1. James Server
  2. JAMES-1013

DO NOT Upgrade camel 2.2.0 to 2.3.0 - IMPORTENT!!!

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 3.0-M1
    • Labels:
      None

      Description

      god save me.

      i have been in this trouble for 4 days.

      this is a really big problem in camel 2.3.0 though 2.2.0 in James 3 now.

      --------------------------------------------------------------------------------------------------

      Channel[
      Splitter[
      on: BeanExpression[
      bean:org.apache.james.transport.camel.MatcherSplitter@70fa2904 method: null
      ] to: Pipeline[
      Channel[
      choice

      {when org.apache.james.transport.camel.MatcherMatch@379aff8e: Channel[ org.apache.james.transport.camel.MailetProcessor@20ffe027 ]}

      ], Channel[
      choice

      {when org.apache.james.transport.camel.MailStateEquals@7ed5315d: Pipeline[ Channel[ org.apache.james.transport.camel.DisposeProcessor@4eb8a7ce ], Channel[ Stop ] ], when org.apache.james.transport.camel.MailStateNotEquals@5e9c11b8: Pipeline[ Channel[ BeanProcessor[ bean: mailClaimCheck ] ], Channel[ RecipientList[ BeanExpression[ bean:org.apache.james.transport.camel.JMSRecipientList@584f778e method: null ] ] ], Channel[ Stop ], Channel[ removeProperty(matcher) ], Channel[ removeProperty(onMatchException) ], Channel[ removeProperty(logger) ] ]}

      ]
      ] aggregate: UseOriginalAggregationStrategy
      ]
      ]

      ---------------------------------------------------------------------------

      see Stop Chanel in MailStateEquals part generated by camel(test with RecipientIsLocal mailet in transport processor in spoolmanager.xml)

      it will not kill the current processor complete.

      HostIsLocal mailet will always be continue.

      i think it is caused by camel 2.3.0's thread lock or some other sync mechanism.

        Issue Links

          Activity

          Norman Maurer added a comment -

          So you say it only happens with camel 2.3.0 with 2.2.0 everything works ?

          tadpale added a comment -

          i think so

          Norman Maurer added a comment -

          Sorry for the delay.. The issue got lost in my inbox Can you give us a bit more info about the "HostIsLocal mailet will always be continue. " ? I mean is the mail just not processed, stuck or what ? Thx

          Norman Maurer added a comment -

          Upgraded to camel 2.4.0 and specify the aggregationStrategy explicit, because the default has changed. This caused the trouble you noticed before.
          See: http://camel.apache.org/camel-230-release.html (Important changes to consider when upgrading)


            People

            • Assignee:
              Norman Maurer
              Reporter:
              tadpale
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development