Uploaded image for project: 'IvyDE'
  1. IvyDE
  2. IVYDE-91

NPE when setting a bad file for the ivy setting path in the global configuration panel

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.0.0.alpha1
    • 2.0.0.alpha1
    • None
    • None

    Description

      Here is the stack trace:

      java.lang.NullPointerException
      at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.getMetaArtifactPath(IvyResolveJob.java:453)
      at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.getSourcesArtifactPath(IvyResolveJob.java:415)
      at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.artifacts2ClasspathEntries(IvyResolveJob.java:388)
      at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.access$6(IvyResolveJob.java:381)
      at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob$1.run(IvyResolveJob.java:257)
      

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            hibou Nicolas Lalevée
            hibou Nicolas Lalevée
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment