IvyDE
  1. IvyDE
  2. IVYDE-35

Parsing ivy file fails in IvyDE while it succeeds in Ant

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 2.0.0.final
    • Component/s: classpath container
    • Labels:
      None

      Description

      Hi,

      I receive the following error when doing a resolve:

      === eclipse log file ===
      !ENTRY org.jayasoft.ivyde.eclipse 1 0 2006-10-10 16:13:06.484
      !MESSAGE resolved dependencies of C:\working\vhs\scontra_vhscontract\ant\ivy.xml

      !ENTRY org.jayasoft.ivyde.eclipse 4 4 2006-10-10 16:13:06.494
      !MESSAGE Impossible to resolve dependencies of [ LCMB | scontra-vhscontract | NONE ]:
      unresolved dependency: [ OTHER | velocity | 1.4 ]: java.text.ParseException: [[Fatal Error] c:\working\repository\commons\lcm\ant_build\ivy\velocity-1.4.ivy:1:-1: Document root element is missing. in c:\working\repository\commons\lcm\ant_build\ivy\velocity-1.4.ivy
      ]

      See IvyConsole for further details
      === end ===

      However, I checked the velocity-1.4.ivy file and the XML is correct.
      Even more, if I resolve the ivy file using ant, there is no problem parsing the velocity-1.4.ivy file

      regards,
      Maarten

      1. ASF.LICENSE.NOT.GRANTED--velocity-1.4.ivy
        0.5 kB
        Maarten Coene
      2. ivy.xml
        9 kB
        Bill Habermaas

        Activity

        Maarten Coene added a comment -

        btw, I'm using Eclipse 3.2.1

        Xavier Hanin added a comment -

        Could you post the ivy file you have for velocity to help investigate on the subject? The problem is very strange, and I think it's something related to the xml parser used. So more details about your environment (both in ant and eclipse) could help (java version, xerces version, ...)

        Maarten Coene added a comment -

        Hi,

        I've taken a look at my ivy file with a HEX viewer, and saw the file started with a Byte Order Mark.
        http://en.wikipedia.org/wiki/Byte_Order_Mark

        So it seems that the standard XML parser from eclipse can't handle this BOM, while in Xerces (which is used by Ant) does the job well.
        Perhaps IvyDE should tell eclipse to use xerces to parse the ivy files??

        For the versions:
        I use a default Eclipse 3.2.1 + WTP 1.5.1 install
        I use a default Ant 1.6.5 + Java 1.4.2

        I'll upload the ivy file in a minute

        Maarten

        Xavier Hanin added a comment -

        Have a look at this thread on javalobby:
        http://www.javalobby.org/java/forums/t16751.html

        The problem may come from invisible characters, well accepted by one parser (or one java version) but not the other. Try to see if it's your case or not.

        Xavier Hanin added a comment -

        It seems we came to the same conclusion

        Forcing to use xerces from IvyDE is not easy as far as I know. If someone know how to do that, please let me know.

        Maarten Coene added a comment -

        Indeed

        Maybe you can include a recent xerces.jar in your lib folder, like some other plugins do... (I don't know, I'm only an Eclipse user)
        In the meantime, I'll remove these characters from my ivy file. I have no idea how they got in there in the first place...

        Maarten

        Maarten Coene added a comment -

        An ivy file which starts with a BOM.

        Bill Habermaas added a comment -

        I have installed 2.0.0.beta1 and still have this problem on Eclipse 3.4 (Ganymede). Is there any way around this problem? It seems to be a show stopper for anyone wanting to work on Apache open source projects on Eclipse.

        Nicolas Lalevée added a comment -

        Well, it works for me.
        I use an Eclipse SDK 3.4.1 on Linux, with sun's jvm 1.6.0_10.
        When listing the files in the plugins directory, I found org.apache.xerces_2.9.0.v200805270400.jar

        Could someone provide some detail about its configuration on which it is failing ? Eclipse version and kind, jvm, os and if any, the version of xerces in the plugins directory.

        Maarten Coene added a comment -

        I could reproduce it when I run Eclipse 3.4.1 classic with sun jvm 1.4.2_16.
        There is no xerces in my plugins directory.

        When I configure Eclipse to use a 1.5+ jre, the problem seems fixed.

        Nicolas Lalevée added a comment -

        Ok, thanks. I have been able to reproduce it.

        After some googling I have found this comment:
        http://www.jdom.org/pipermail/jdom-interest/2005-March/014721.html

        The default XML parser in JDK 1.4 is Crimson, the default parser in JDK 1.5
        is Xerces. Xerces accepts a BOM marker in UTF-8 files, Crimson does not. The
        original XML 1.0 specification was not explicit as to whether a BOM was
        allowed in UTF-8 files, this has been clarified in later specs but many
        parsers have not been updated.

        With OSGi we can have a pretty good control of the classpath, so we should be able to make Ivy use Xerces, just like WTP does:
        http://wiki.eclipse.org/FAQ_Why_doesn't_Eclipse_play_well_with_Xerces%3F

        Bill Habermaas added a comment -

        I am using Eclipse 3.4.0 on windows/XP with jdk1.6.0_10.
        There is xerces in my plugins directory.

        I have also tried a similar configuration on Ubuntu with the same failure. So I doubt this is a windows related problem.

        If this is because I do not have the xerces parser then where can i find it?

        Nicolas Lalevée added a comment -

        Bill, do you have the same issue Maarten had: an ivy file with a BOM marker ? If not could you attach here your problematic ivy file ?

        Bill Habermaas added a comment -

        I checked for a BOM marker and as far as I can tell there isn't one. The ivy file I am trying to use is taken from the Apache Hadoop trunk. It works fine if I run ant by itself but not when run under Eclipse. I am attaching the file to this jira.

        Maarten Coene added a comment -

        Bill, what's the error message you receive?
        Did you define all these properties used in the ivy.xml somewhere?

        Bill Habermaas added a comment -

        Whenever I open my hadoop trunk project I get a dialog box saying 'Resolve project 'trunk' and ivy file 'ivy.xml' dependencies has encountered a problem. When I click the details button I get the following:
        Impossible to resolve dependencies of org.apache.hadoop#$

        {ant.project.name}

        ;working@Habermaas
        unresolved dependency: commons-logging#commons-logging;$

        {commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: xmlenc#xmlenc;${xmlenc.version}: not found
        unresolved dependency: net.java.dev.jets3t#jets3t;${jets3t.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}: not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;${servlet-api-2.5.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}

        : not found
        unresolved dependency: log4j#log4j;$

        {log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: xmlenc#xmlenc;${xmlenc.version}: not found
        unresolved dependency: net.java.dev.jets3t#jets3t;${jets3t.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}: not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;${servlet-api-2.5.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}

        : not found
        unresolved dependency: commons-logging#commons-logging;$

        {commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}

        : not found
        unresolved dependency: log4j#log4j;$

        {log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: xmlenc#xmlenc;${xmlenc.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}

        : not found
        unresolved dependency: commons-httpclient#commons-httpclient;$

        {commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: net.java.dev.jets3t#jets3t;${jets3t.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}: not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;${servlet-api-2.5.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}

        : not found
        unresolved dependency: commons-codec#commons-codec;$

        {commons-codec.version}: not found
        unresolved dependency: net.java.dev.jets3t#jets3t;${jets3t.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}: not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;${servlet-api-2.5.version}: not found
        unresolved dependency: xmlenc#xmlenc;${xmlenc.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty;${jetty.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty-util;${jetty-util.version}: not found
        unresolved dependency: tomcat#jasper-runtime;${jasper.version}: not found
        unresolved dependency: tomcat#jasper-compiler;${jasper.version}: not found
        unresolved dependency: commons-el#commons-el;${commons-el.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}

        : not found
        unresolved dependency: xmlenc#xmlenc;$

        {xmlenc.version}: not found
        unresolved dependency: net.java.dev.jets3t#jets3t;${jets3t.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}: not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;${servlet-api-2.5.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty;${jetty.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty-util;${jetty-util.version}: not found
        unresolved dependency: tomcat#jasper-runtime;${jasper.version}: not found
        unresolved dependency: tomcat#jasper-compiler;${jasper.version}: not found
        unresolved dependency: commons-el#commons-el;${commons-el.version}: not found
        unresolved dependency: junit#junit;${junit.version}: not found
        unresolved dependency: commons-logging#commons-logging-api;${commons-logging-api.version}: not found
        unresolved dependency: org.slf4j#slf4j-api;${slf4j-api.version}: not found
        unresolved dependency: org.eclipse.jdt#core;${core.version}: not found
        unresolved dependency: oro#oro;${oro.version}: not found
        unresolved dependency: org.slf4j#slf4j-log4j12;${slf4j-log4j12.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: xmlenc#xmlenc;${xmlenc.version}

        : not found
        unresolved dependency: net.java.dev.jets3t#jets3t;$

        {jets3t.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}: not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;${servlet-api-2.5.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty;${jetty.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty-util;${jetty-util.version}: not found
        unresolved dependency: tomcat#jasper-runtime;${jasper.version}: not found
        unresolved dependency: tomcat#jasper-compiler;${jasper.version}: not found
        unresolved dependency: commons-el#commons-el;${commons-el.version}: not found
        unresolved dependency: junit#junit;${junit.version}: not found
        unresolved dependency: commons-logging#commons-logging-api;${commons-logging-api.version}: not found
        unresolved dependency: org.slf4j#slf4j-api;${slf4j-api.version}: not found
        unresolved dependency: org.eclipse.jdt#core;${core.version}: not found
        unresolved dependency: oro#oro;${oro.version}: not found
        unresolved dependency: org.slf4j#slf4j-log4j12;${slf4j-log4j12.version}: not found
        unresolved dependency: org.apache.lucene#lucene-core;${lucene-core.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: xmlenc#xmlenc;${xmlenc.version}: not found
        unresolved dependency: net.java.dev.jets3t#jets3t;${jets3t.version}

        : not found
        unresolved dependency: commons-net#commons-net;$

        {commons-net.version}: not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;${servlet-api-2.5.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty;${jetty.version}: not found
        unresolved dependency: org.mortbay.jetty#jetty-util;${jetty-util.version}: not found
        unresolved dependency: tomcat#jasper-runtime;${jasper.version}: not found
        unresolved dependency: tomcat#jasper-compiler;${jasper.version}: not found
        unresolved dependency: commons-el#commons-el;${commons-el.version}: not found
        unresolved dependency: junit#junit;${junit.version}: not found
        unresolved dependency: commons-logging#commons-logging-api;${commons-logging-api.version}: not found
        unresolved dependency: org.slf4j#slf4j-api;${slf4j-api.version}: not found
        unresolved dependency: org.eclipse.jdt#core;${core.version}: not found
        unresolved dependency: oro#oro;${oro.version}: not found
        unresolved dependency: org.slf4j#slf4j-log4j12;${slf4j-log4j12.version}: not found
        unresolved dependency: com.google.code.p.arat#rat-lib;${rats-lib.version}: not found
        unresolved dependency: commons-lang#commons-lang;${commons-lang.version}: not found
        unresolved dependency: commons-collections#commons-collections;${commons-collections.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: log4j#log4j;${log4j.version}: not found
        unresolved dependency: commons-logging#commons-logging;${commons-logging.version}: not found
        unresolved dependency: commons-httpclient#commons-httpclient;${commons-httpclient.version}: not found
        unresolved dependency: commons-codec#commons-codec;${commons-codec.version}: not found
        unresolved dependency: net.java.dev.jets3t#jets3t;${jets3t.version}: not found
        unresolved dependency: commons-net#commons-net;${commons-net.version}

        : not found
        unresolved dependency: org.mortbay.jetty#servlet-api-2.5;$

        {servlet-api-2.5.version}

        : not found
        unresolved dependency: org.mortbay.jetty#jetty;$

        {jetty.version}

        : not found
        unresolved dependency: org.mortbay.jetty#jetty-util;$

        {jetty-util.version}

        : not found
        unresolved dependency: tomcat#jasper-runtime;$

        {jasper.version}: not found
        unresolved dependency: tomcat#jasper-compiler;${jasper.version}

        : not found
        unresolved dependency: commons-el#commons-el;$

        {commons-el.version}

        : not found
        unresolved dependency: xmlenc#xmlenc;$

        {xmlenc.version}

        : not found
        unresolved dependency: jdiff#jdiff;$

        {jdiff.version}

        : not found
        unresolved dependency: xerces#xerces;$

        {xerces.version}

        : not found
        unresolved dependency: checkstyle#checkstyle;$

        {checkstyle.version}

        : not found

        Maarten Coene added a comment - - edited

        You get this error because IvyDE/Ivy doesn't know how to replace all these properties like $

        {commons-logging.version}

        , $

        {log4j.version}

        , etc.
        I don't know how you load these properties in Ant, but if they are defined in a properties file, you could load that properties file in your ivysettings.xml.

        Nicolas: is it already possible to load such properties files from within IvyDE?

        Bill Habermaas added a comment -

        In the apache hadoop project there is an ivy subfolder that contains ivysettings.xml and libraries.properties. These are likely the things that ant uses to get everything resolved. Is there the same mechanism for IvyDE?

        Nicolas Lalevée added a comment -

        You can make IvyDE load thoses properties file, this feature has been recently added : IVYDE-13. You should try using the trunk version of IvyDE.

        Nicolas Lalevée added a comment -

        I have been able to resolve the issue.

        The SaxParserFactory search for the file META-INF/services/javax.xml.parsers.SAXParserFactory in the classpath, with the context class loader.
        Then the solution was to add xerces as a required dependency of IvyDE, so xerces will be found in IvyDE classloader before the javax.xml packages of the jre. And I made the thread calling Ivy using an IvyDE class loader as context class loader.
        I also had to fix Ivy so we can have control over the context class loader used, see r747794.

        Nicolas Lalevée added a comment -

        I forgot to say, xerces is an optional dependency, so people having parsing errors will have to get xerces by themself: use the Eclipse update manager, search for xerces (you should find it under Ganymede/Uncategorized/Apache Xerces), and install it.

        Maarten Coene added a comment -

        Thanks Nicolas.
        Maybe we could mention this somewhere in the documentation?
        Or does Eclipse shows an option to download the Xerces plugin when installing IvyDE?

        Nicolas Lalevée added a comment -

        yep you're right, I will add an entry in the FAQ.


          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Maarten Coene
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development