Uploaded image for project: 'IvyDE'
  1. IvyDE
  2. IVYDE-330

md5 checksums inconsistent with eclipse plugin file downloads?

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0.beta1
    • Fix Version/s: None
    • Component/s: ivy editor
    • Environment:

      Mac OSX + Eclipse Juno

      Description

      Using the update site http://www.apache.org/dist/ant/ivyde/updatesite

      and the standard Eclipse "Install new software" under Help, select

      Apache Ivy library
      Apache IvyDE Eclipse plugins

      get the following error:

      'Installing Software' has encountered a problem

      An error occurred while collecting items to be installed

      An error occurred while collecting items to be installed
      session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
      Failed to transfer artifact canonical: osgi.bundle,org.apache.ivy.eclipse.ant,2.3.0.cr2_20121105223351.
      Retry another mirror
      Problems downloading artifact: osgi.bundle,org.apache.ivy.eclipse.ant,2.3.0.cr2_20121105223351.
      MD5 hash is not as expected. Expected: be1ad9be23cc73af4b2cd45ea7df4593 and found 246da7aee85b27609a980a36803d1664.

      We suspect the md5 checksums are not consistent with the files on the server because if we download the jars directly and drop them into the relevant Eclipse folders, everything works.

      The following additional info is from the Eclipse .metadata/.log file:

      !ENTRY org.eclipse.equinox.p2.engine 4 4 2012-11-15 15:42:31.058
      !MESSAGE An error occurred while collecting items to be installed
      !SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2012-11-15 15:42:31.058
      !MESSAGE session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
      !SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2012-11-15 15:42:31.058
      !MESSAGE Failed to transfer artifact canonical: osgi.bundle,org.apache.ivy.eclipse.ant,2.3.0.cr2_20121105223351.
      !SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 4 13 2012-11-15 15:42:31.058
      !MESSAGE Retry another mirror

        Attachments

          Activity

            People

            • Assignee:
              maartenc Maarten Coene
              Reporter:
              nhambly Nigel Hambly
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: