IvyDE
  1. IvyDE
  2. IVYDE-228

Can not add a project specific property file when adding a library

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0.final
    • Fix Version/s: 2.1.0
    • Component/s: classpath container
    • Labels:
      None
    • Environment:

      Eclipse 3.5

      Description

      I right click on a ivy.xml file and select Add Ivy Library, then I select the Enable project specific settings.
      And add a entry into the Property files text box but it never loads it.

      If I add in the global location then it does see the properties file and loads it correctly.

      It would also be nice if there was a browse button on this field too.

        Activity

        Dan Diodati created issue -
        Nicolas Lalevée added a comment -

        I just tested with IvyDE 2.0.0 final and the trunk version, both works for me with the following setup:

        • the settings.xml:
          <ivysettings>
              <settings defaultResolver="${defaultResolver}" />
              <resolvers>
                  <ibiblio name="ibiblio" m2compatible="true" />
              </resolvers>
          </ivysettings>
          
        • the settings.properties:
          defaultResolver=ibiblio
          

        Could you give more info about your setup ?

        About the browsing button, there will be several see IVYDE-152

        Nicolas Lalevée added a comment -

        as it works for me, I won't make it a blocker for the release of the next version, so I remove the fix version.

        Nicolas Lalevée made changes -
        Field Original Value New Value
        Fix Version/s 2.0.1 [ 12314065 ]
        Dan Diodati added a comment -

        The problem occurs from the ivy.xml having a property not the ivysettings.xml.

        The ivy.xml includes a outside file for its defaults configurations. So our ivy.xml contains a section like:

        <configurations>
        <include file="$

        {build.system.dir}

        /default-ivy-configurations.xml"/>
        </configurations>

        So I need to define a property file that defines the build.system.dir property. This works only in the global area but not in the project specific area.

        Dan Diodati added a comment -

        This is occuring in eclipse 3.5 and Mac OSX 10.5.8 for me.

        Nicolas Lalevée added a comment -

        Thanks for the further details.
        I have been able to reproduce the error. More precisely what I found is that during the creation of the container, the UI complains that the property cannot be found. But if you force the creation by clicking finish despite the errors, the resolve is successful.
        So I have fixed the UI so it does take into account the property files.

        Nicolas Lalevée made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Nicolas Lalevée [ hibou ]
        Fix Version/s 2.1.0 [ 12314066 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        4d 22h 43m 1 Nicolas Lalevée 12/Jan/10 19:36

          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Dan Diodati
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development