IvyDE
  1. IvyDE
  2. IVYDE-182

Importing a project with Ivy fails if properties files are specified in settings

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0.beta1
    • Fix Version/s: 2.0.0.final
    • Component/s: None
    • Labels:
      None
    • Environment:

      Eclipse SDK Version: 3.4.1
      Build id: M20080911-1700
      Ubuntu Linux 9.0.4

      Description

      Specifying a property file in settings and then importing ivy projects into the workspace causes IvyDE to fail during import, complaining that it can't find the property file. Removing and re-adding the ivy library by hand after the import works fine, as the property file does exist. It appears that IvyDE is trying to use the facilities of the project to locate the file prior to the project's instantiation into the workspace. This may be related to IVYDE-181.

      relevant .log entry:

      !ENTRY org.apache.ivyde.eclipse 4 4 2009-05-27 12:03:59.668
      !MESSAGE Error while resolving the ivy instance for ivy.xml in 'myproj':
      The property file 'build.properties' could not be read
      !STACK 0
      org.apache.ivyde.eclipse.IvyDEException: Error while resolving the ivy instance for ivy.xml in 'base-web':
      The property file 'build.properties' could not be read
      at org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerConfiguration.createIvySettings(IvyClasspathContainerConfiguration.java:628)
      at org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerConfiguration.getIvy(IvyClasspathContainerConfiguration.java:573)
      at org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerConfiguration.doGetIvy(IvyClasspathContainerConfiguration.java:535)
      at org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerConfiguration.getIvy(IvyClasspathContainerConfiguration.java:453)
      at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob.run(IvyResolveJob.java:200)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
      Caused by: org.eclipse.core.internal.resources.ResourceException: Resource '/base-web/build.properties' does not exist.
      at org.eclipse.core.internal.resources.Resource.checkExists(Resource.java:317)
      at org.eclipse.core.internal.resources.Resource.checkAccessible(Resource.java:194)
      at org.eclipse.core.internal.resources.File.getContents(File.java:296)
      at org.eclipse.core.internal.resources.File.getContents(File.java:287)
      at org.apache.ivyde.eclipse.cpcontainer.IvyClasspathContainerConfiguration.createIvySettings(IvyClasspathContainerConfiguration.java:626)
      ... 5 more

        Activity

        Nicolas Lalevée added a comment -

        Your are right, it was just like IVYDE-181. Thank you for the bug report.

        Adrian Gould added a comment -

        No problem. Thanks for fixing it!


          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Adrian Gould
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development