IvyDE
  1. IvyDE
  2. IVYDE-176

Refresh action is detaching javadoc and sources

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0.0.final
    • Component/s: None
    • Labels:
      None
    • Environment:

      linux eclipse 3.4.2 sr2 x64

      Description

      If you do refresh after a successful resolve (properly get sources/javadocs for your artifacts) the sources/javadocs are removed.

      1. IVYDE-176_patch.txt
        3 kB
        Daniel Becheanu

        Activity

        Nicolas Lalevée added a comment -

        I have reproduced the bug.

        I have not tested your patch, but it seems it tries to download the artifact which have the extra attributes m:classifier=sources.
        First it seems to me wrong to try to download something which doing a simple refresh, you should only try with the data in cache. And then this solution would only work on mavenish module descriptor due to the extra attribute.

        Looking closer to the code, I think it fails beacuse in the IvyResolveJob, when it tries to parse the resolve report, it doesn't fill the 'artifactsByDependency' map. So we should better use the ivy api to get from the cache the info to populate that map.

        Nicolas Lalevée added a comment -

        I have implemented a fix that use the Ivy API to get metadata from the cache about some source artifacts. As far as I could test I works now correctly.
        Please let me know if it doesn't fix your use case.


          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Daniel Becheanu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development