IvyDE
  1. IvyDE
  2. IVYDE-170

dependency order not preserved causing failed builds

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0.beta1
    • Fix Version/s: 2.1.0
    • Component/s: classpath container
    • Labels:
      None
    • Environment:

      eclipse ganymede on redhat linux

      Description

      When I expand the ivy.xml tree in the package explorer the jar files are not in the same order they are in the ivy.xml file on the system. In one particular case we have multiple corba libraries with conflicting method signatures. Building on the command line works but building in eclipse picks up the wrong jar first and thus fails. In another case we have multiple XML implementation jars. Building on the command line works but building in eclipse picks up the wrong jar first and does not compile.

      1. Screenshot.jpg
        71 kB
        Jeff Johnston

        Activity

        Jeff Johnston added a comment -

        Attached is a screenshot showing jacorb-core-2.2.4.jar appearing before orbacus.core-4.1.2.jar when expanding the ivy.xml node in eclipse. In the dependencies below you can see that orbacus appears before jacorb. The build works fine from the command line but fails in eclipse.

        <dependency org="org.jibx" name="jibx-run" rev="1.1.3" conf="runtime" />
        <dependency org="quartz" name="quartz" rev="1.5.2" conf="runtime" />
        <dependency org="com.orbacus" name="notify-core" rev="2.0" conf="runtime" />
        <dependency org="log4j" name="log4j" rev="1.2.12" conf="runtime" />
        <dependency org="com.orbacus" name="orbacus-core" rev="4.1.2" conf="runtime" />
        <dependency org="com.orbacus" name="orbacus-event" rev="4.1.2" conf="runtime" />
        <dependency org="javax.jms" name="jms" rev="1.1" conf="runtime" />
        <dependency org="javax.servlet" name="servlet-api" rev="2.3" conf="runtime" />
        <dependency org="com.oracle" name="ojdbc14" rev="10.2.0.3.0" conf="runtime" />
        <dependency org="org.jacorb" name="jacorb-core" rev="2.2.4" conf="runtime" />
        <dependency org="commons-logging" name="commons-logging" rev="1.1.1" conf="runtime" />

        Nicolas Lalevée added a comment -

        I tried with a very simple project, it works for me. May with transitive dependencies the bug will show up.
        Could you attach here an ivy dependency report of your project ?

        Nicolas Lalevée added a comment -

        Whereas I was not capabale of reproducing the bug, I find some little difference between IvyCacheTask and IvyDE. So now IvyDE is having the exact same algorithm as IvyCacheTask. I hope it will fix the bug. You are welcomed to reopen if this is not the case.


          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Jeff Johnston
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development