Ivy
  1. Ivy
  2. IVY-802

The Bundle-Version is 0.0.0 is the build artifacts

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-beta-2
    • Fix Version/s: 2.0-RC1
    • Component/s: None
    • Labels:
      None

      Description

      The regexep introduced in IVY-687 is not matching any line, so the Bundle-Version is not replaced.
      Unfortunately the beta-2 release contains the 0.0.0 version number, so it cannot be included in an OSGi environment without modifying it.

        Activity

        Hide
        Nicolas Lalevée added a comment -

        fixed by using replaceregexp filter which is simpler and is still compatible with Ant 1.6

        Show
        Nicolas Lalevée added a comment - fixed by using replaceregexp filter which is simpler and is still compatible with Ant 1.6
        Hide
        Jim Adams added a comment -

        I just downloaded RC2 and noticed that the Bundle-Version is still 0.0.0

        Show
        Jim Adams added a comment - I just downloaded RC2 and noticed that the Bundle-Version is still 0.0.0
        Hide
        Jim Adams added a comment -

        OOPS! Just realized I was looking at the source for the manifest and not the output of the buld. Nevermind!

        Show
        Jim Adams added a comment - OOPS! Just realized I was looking at the source for the manifest and not the output of the buld. Nevermind!

          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Nicolas Lalevée
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development