Ivy
  1. Ivy
  2. IVY-62

'null' status attribute in module descriptor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Component/s: Core
    • Labels:
      None

      Description

      The module descriptor writer blindly outputs module descriptor attributes without checking for null.

      So the descriptor in the cache ends up with "null":

      <info organisation="jayasoft" module="depending" revision="working@hostname" status="null"/>

        Activity

        Stephane Bailliez created issue -
        Xavier Hanin added a comment -

        IMHO the problem is more due to the fact that a status should never be null. So I've updated the DefaultModuleDescriptor so that status defaults to the default status (integration), so that it should never be null again.

        Jeff Turner made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        484d 12h 17m 1 Jeff Turner 26/Nov/06 07:03

          People

          • Assignee:
            Xavier Hanin
            Reporter:
            Stephane Bailliez
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Development