Uploaded image for project: 'Ivy'
  1. Ivy
  2. IVY-1504

ArrayIndexOutOfBoundsException when using a p2 repository for dependencies

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.5.0-rc1
    • Component/s: None
    • Labels:
      None
    • Environment:

      Linux, SBT 0.13.7

      Description

      I've reported first the bug in the SBT, but I think the problem lies more in Ivy.

      Here is a link:

      https://github.com/sbt/sbt/issues/1788

      java.lang.NullPointerException at org.apache.ivy.osgi.p2.P2MetadataParser.namespace2Type(P2MetadataParser.java:338)
      [error] 0
      java.lang.ArrayIndexOutOfBoundsException: 0
      at org.apache.ivy.util.StringUtils.getErrorMessage(StringUtils.java:64)
      at org.apache.ivy.core.resolve.IvyNode.getProblemMessage(IvyNode.java:937)
      at org.apache.ivy.plugins.report.LogReportOutputter.output(LogReportOutputter.java:148)
      at org.apache.ivy.core.report.ResolveReport.output(ResolveReport.java:99)
      

        Attachments

          Activity

            People

            • Assignee:
              hibou Nicolas Lalevée
              Reporter:
              David Pérez David Pérez
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: