Ivy
  1. Ivy
  2. IVY-1438

ParseException when "Bundle-Description" is present in OSGI MANIFEST.MF

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.4.0-RC1
    • Component/s: Core
    • Labels:
      None

      Description

      When a "Bundle-Description" is present in a parsed "MANIFEST.MF" file then a ParseException is thrown.

      EXAMPLE (from Eclipse 4.2.2 "plugin" Directory):
      javax.servlet_3.0.0.v201112011016.jar!/META-INF/MANIFEST.MF

      DESCRIPTION (from above manifest):
      Bundle-Description: glassfish javax.servlet.3.1.0.b33

      EXCEPTION:
      Caused by: java.text.ParseException: Expecting the end of a value or of an parameter name
      at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:179)
      at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:175)
      at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseValueOrParameter(ManifestHeaderValue.java:218)
      at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseElement(ManifestHeaderValue.java:185)
      at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parse(ManifestHeaderValue.java:155)
      at org.apache.ivy.osgi.core.ManifestHeaderValue.<init>(ManifestHeaderValue.java:51)
      at org.apache.ivy.osgi.core.ManifestParser.parseManifest(ManifestParser.java:107)

      REPRODUCE:

      Try to create a ManifestHeaderValue like this:

       
      new ManifestHeaderValue("glassfish javax.servlet.3.1.0.b33")
      

        Activity

        Michael Schnell created issue -
        Michael Schnell made changes -
        Field Original Value New Value
        Attachment javax.servlet_3.0.0.v201112011016.jar [ 12602048 ]
        Michael Schnell made changes -
        Description When a "Bundle-Description" is present in a parsed "MANIFEST.MF" file then a ParseException is thrown.

        *EXAMPLE* (from Eclipse 4.2.2 "plugin" Directory):
        javax.servlet_3.0.0.v201112011016.jar!/META-INF/MANIFEST.MF

        *DESCRIPTION* (from above manifest):
        Bundle-Description: glassfish javax.servlet.3.1.0.b33

        *EXCEPTION*:
        Caused by: java.text.ParseException: Expecting the end of a value or of an parameter name
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:179)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:175)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseValueOrParameter(ManifestHeaderValue.java:218)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseElement(ManifestHeaderValue.java:185)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parse(ManifestHeaderValue.java:155)
        at org.apache.ivy.osgi.core.ManifestHeaderValue.<init>(ManifestHeaderValue.java:51)
        at org.apache.ivy.osgi.core.ManifestParser.parseManifest(ManifestParser.java:107)


        When a "Bundle-Description" is present in a parsed "MANIFEST.MF" file then a ParseException is thrown.

        *EXAMPLE* (from Eclipse 4.2.2 "plugin" Directory):
        javax.servlet_3.0.0.v201112011016.jar!/META-INF/MANIFEST.MF

        *DESCRIPTION* (from above manifest):
        Bundle-Description: glassfish javax.servlet.3.1.0.b33

        *EXCEPTION*:
        Caused by: java.text.ParseException: Expecting the end of a value or of an parameter name
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:179)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:175)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseValueOrParameter(ManifestHeaderValue.java:218)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseElement(ManifestHeaderValue.java:185)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parse(ManifestHeaderValue.java:155)
        at org.apache.ivy.osgi.core.ManifestHeaderValue.<init>(ManifestHeaderValue.java:51)
        at org.apache.ivy.osgi.core.ManifestParser.parseManifest(ManifestParser.java:107)

        *REPRODUCE*:
        Just try to create a ManifestHeaderValue Header like this:
        {code:java}
        new ManifestHeaderValue("glassfish javax.servlet.3.1.0.b33")
        {code}
        Michael Schnell made changes -
        Description When a "Bundle-Description" is present in a parsed "MANIFEST.MF" file then a ParseException is thrown.

        *EXAMPLE* (from Eclipse 4.2.2 "plugin" Directory):
        javax.servlet_3.0.0.v201112011016.jar!/META-INF/MANIFEST.MF

        *DESCRIPTION* (from above manifest):
        Bundle-Description: glassfish javax.servlet.3.1.0.b33

        *EXCEPTION*:
        Caused by: java.text.ParseException: Expecting the end of a value or of an parameter name
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:179)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:175)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseValueOrParameter(ManifestHeaderValue.java:218)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseElement(ManifestHeaderValue.java:185)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parse(ManifestHeaderValue.java:155)
        at org.apache.ivy.osgi.core.ManifestHeaderValue.<init>(ManifestHeaderValue.java:51)
        at org.apache.ivy.osgi.core.ManifestParser.parseManifest(ManifestParser.java:107)

        *REPRODUCE*:
        Just try to create a ManifestHeaderValue Header like this:
        {code:java}
        new ManifestHeaderValue("glassfish javax.servlet.3.1.0.b33")
        {code}
        When a "Bundle-Description" is present in a parsed "MANIFEST.MF" file then a ParseException is thrown.

        *EXAMPLE* (from Eclipse 4.2.2 "plugin" Directory):
        javax.servlet_3.0.0.v201112011016.jar!/META-INF/MANIFEST.MF

        *DESCRIPTION* (from above manifest):
        Bundle-Description: glassfish javax.servlet.3.1.0.b33

        *EXCEPTION*:
        Caused by: java.text.ParseException: Expecting the end of a value or of an parameter name
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:179)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:175)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseValueOrParameter(ManifestHeaderValue.java:218)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseElement(ManifestHeaderValue.java:185)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parse(ManifestHeaderValue.java:155)
        at org.apache.ivy.osgi.core.ManifestHeaderValue.<init>(ManifestHeaderValue.java:51)
        at org.apache.ivy.osgi.core.ManifestParser.parseManifest(ManifestParser.java:107)

        *REPRODUCE*:

        Try to create a ManifestHeaderValue like this:

        {code:java}
        new ManifestHeaderValue("glassfish javax.servlet.3.1.0.b33")
        {code}
        Michael Schnell made changes -
        Description When a "Bundle-Description" is present in a parsed "MANIFEST.MF" file then a ParseException is thrown.

        *EXAMPLE* (from Eclipse 4.2.2 "plugin" Directory):
        javax.servlet_3.0.0.v201112011016.jar!/META-INF/MANIFEST.MF

        *DESCRIPTION* (from above manifest):
        Bundle-Description: glassfish javax.servlet.3.1.0.b33

        *EXCEPTION*:
        Caused by: java.text.ParseException: Expecting the end of a value or of an parameter name
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:179)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:175)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseValueOrParameter(ManifestHeaderValue.java:218)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseElement(ManifestHeaderValue.java:185)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parse(ManifestHeaderValue.java:155)
        at org.apache.ivy.osgi.core.ManifestHeaderValue.<init>(ManifestHeaderValue.java:51)
        at org.apache.ivy.osgi.core.ManifestParser.parseManifest(ManifestParser.java:107)

        *REPRODUCE*:

        Try to create a ManifestHeaderValue like this:

        {code:java}
        new ManifestHeaderValue("glassfish javax.servlet.3.1.0.b33")
        {code}
        When a "Bundle-Description" is present in a parsed "MANIFEST.MF" file then a ParseException is thrown.

        *EXAMPLE* (from Eclipse 4.2.2 "plugin" Directory):
        javax.servlet_3.0.0.v201112011016.jar!/META-INF/MANIFEST.MF

        *DESCRIPTION* (from above manifest):
        Bundle-Description: glassfish javax.servlet.3.1.0.b33

        *EXCEPTION*:
        Caused by: java.text.ParseException: Expecting the end of a value or of an parameter name
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:179)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.error(ManifestHeaderValue.java:175)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseValueOrParameter(ManifestHeaderValue.java:218)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parseElement(ManifestHeaderValue.java:185)
        at org.apache.ivy.osgi.core.ManifestHeaderValue$ManifestHeaderParser.parse(ManifestHeaderValue.java:155)
        at org.apache.ivy.osgi.core.ManifestHeaderValue.<init>(ManifestHeaderValue.java:51)
        at org.apache.ivy.osgi.core.ManifestParser.parseManifest(ManifestParser.java:107)

        *REPRODUCE*:

        Try to create a ManifestHeaderValue like this:
        {code:java}
        new ManifestHeaderValue("glassfish javax.servlet.3.1.0.b33")
        {code}
        Nicolas Lalevée added a comment -

        Fixed. Thanks for your detailed report.

        Nicolas Lalevée made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Nicolas Lalevée [ hibou ]
        Fix Version/s 2.4.0 [ 12323983 ]
        Resolution Fixed [ 1 ]
        Michael Schnell added a comment -

        Tnx for the quick fix. Works perfect!

        Maarten Coene made changes -
        Fix Version/s 2.4.0-RC1 [ 12326648 ]
        Fix Version/s 2.4.0 [ 12323983 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        4h 51m 1 Nicolas Lalevée 08/Sep/13 15:49

          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Michael Schnell
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development