Ivy
  1. Ivy
  2. IVY-1378

Ivy default cache path with Umlauts lets it crash.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.3.0-RC2
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 7 64 bit
      JDK 1.7
      Netbeans 7.2 with integrated Ant 1.8.3

      Description

      I'm trying to build the Solr 4 beta. When ivy tries to fetch the dependencies into the cache, I get the following message:

      io problem while parsing ivy file: http://repo1.maven.org/maven2/commons-codec/commons-codec/1.6/commons-codec-1.6.pom: Path contains invalid character: ä
      module not found: commons-codec#commons-codec;1.6
      ==== local: tried
      C:\Users\Jochen Schäfer\.ivy2/local/commons-codec/commons-codec/1.6/ivys/ivy.xml
      – artifact commons-codec#commons-codec;1.6!commons-codec.jar:
      C:\Users\Jochen Schäfer\.ivy2/local/commons-codec/commons-codec/1.6/jars/commons-codec.jar
      ==== shared: tried
      C:\Users\Jochen Schäfer\.ivy2/shared/commons-codec/commons-codec/1.6/ivys/ivy.xml
      – artifact commons-codec#commons-codec;1.6!commons-codec.jar:
      C:\Users\Jochen Schäfer\.ivy2/shared/commons-codec/commons-codec/1.6/jars/commons-codec.jar
      ==== public: tried
      http://repo1.maven.org/maven2/commons-codec/commons-codec/1.6/commons-codec-1.6.pom
      ==== sonatype-releases: tried
      http://oss.sonatype.org/content/repositories/releases/commons-codec/commons-codec/1.6/commons-codec-1.6.pom
      – artifact commons-codec#commons-codec;1.6!commons-codec.jar:
      http://oss.sonatype.org/content/repositories/releases/commons-codec/commons-codec/1.6/commons-codec-1.6.jar
      ==== working-chinese-mirror: tried
      http://mirror.netcologne.de/maven2/commons-codec/commons-codec/1.6/commons-codec-1.6.pom
      – artifact commons-codec#commons-codec;1.6!commons-codec.jar:
      http://mirror.netcologne.de/maven2/commons-codec/commons-codec/1.6/commons-codec-1.6.jar
      ::::::::::::::::::::::::::::::::::::::::::::::
      :: UNRESOLVED DEPENDENCIES ::
      ::::::::::::::::::::::::::::::::::::::::::::::
      :: commons-codec#commons-codec;1.6: not found
      ::::::::::::::::::::::::::::::::::::::::::::::

      1. debug.txt
        1.21 MB
        Jochen Schäfer
      2. debug.txt
        50 kB
        Jochen Schäfer
      3. debug.txt
        95 kB
        Jochen Schäfer

        Activity

        Evgeniy Fitsner added a comment -

        To work around the problem, add the following line to the ivysettings.xml which one prevent using ivy default-cache:

        <caches>
        	<cache basedir="C:/.ivy_cache/cache" />
        </caches>
        
        Jochen Schäfer added a comment -

        Thanks Evgeniy.
        I did that workaround already

        Maarten Coene added a comment -

        I cannot reproduce this issue.
        Could you run in verbose mode and post the stacktrace (if any)?

        Jochen Schäfer added a comment -

        I have attached the output of ant with the diagnostics and verbose commands.

        Maarten Coene added a comment -

        Still cannot reproduce the issue, I tried on Vista with JDK1.7.
        Could you also attach the debug log (you don't need to post the whole log, I'm only interested in the exception that caused this io error)

        Evgeniy Fitsner added a comment -

        Maybe this steps are helpfull(for russian users):

        • set system local to RU and system language(within regional settings);
        • restart and create user account from scratch with user name on russian language (please, do not use latin symbols, only russian)
        • login into this new account
        • run Ivy
          After this steps error should occur
        Jochen Schäfer added a comment -

        Now I have attached the debug output.

        Maarten Coene added a comment -

        Thanks Jochen,
        but could you do the same again with a recent snapshot build of Ivy and attach the debug output.
        The debug logging should be better with a recent snapshot build so we can hopefully see what's causing this problem.

        Jochen Schäfer added a comment -

        Ok, I have attached the debug log of the Ivy output using the 2.3.0-rc1 version.

        Maarten Coene added a comment -

        Jochen,
        version 2.3.0-rc1 is also too old. We added more debug information after that release.
        Could you do it again with a recent snapshot? You can find snapshots here: https://builds.apache.org/view/A-F/view/Ant/job/Ivy/

        Maarten

        Jochen Schäfer added a comment -

        Ok. I attached the debug.txt

        Maarten Coene added a comment -

        Jochen, are you sure your latest debug.txt is generated with such a snapshot?
        I see the following in your logfile:

        resolve:
        Setting project property: ivy.version -> 2.3.0-rc1
        

        It seems you still have the 2.3.0-rc1 version somewhere in your classpath...

        Jochen Schäfer added a comment -

        Oh damn. Reminds never to begin work before the first coffee

        I hope this one is better

        Maarten Coene added a comment -

        Jochen,
        thanks for the new debug.txt, it was very helpfull.

        I think I have fixed the problem in SVN trunk (but I'm not sure since I still cannot reproduce the issue).
        Could you give it a try? The latest snapshot build from https://builds.apache.org/view/A-F/view/Ant/job/Ivy/ should contain the fix.
        If it still doesn't work, could you upload a new debug.txt?

        Jochen Schäfer added a comment -

        The new version works like a charm, at least on Windows 7.
        I close the issue.

        Maarten Coene added a comment -

        Glad to see the problem has been solved
        I've also merged the change in the 2.3-branch.


          People

          • Assignee:
            Maarten Coene
            Reporter:
            Jochen Schäfer
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development