Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.0-RC1
    • Fix Version/s: 2.4.0-RC1
    • Component/s: Core
    • Labels:
      None
    • Environment:

      ubuntu 12.04, jdk7.06/32bits, jenkins, jsch 0.1.84, "OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012"

      Description

      when the sftp resolver connects to a remote repository, it sometimes fails to fetch the artifacts.
      This is accompanied by a log entry in the /var/log/auth.log on the server side:

      Aug 30 10:36:02 zzz sshd[1371]: Received disconnect from zzz.zzz.zzz.zzz: 3: com.jcraft.jsch.JSchException: verify: false [preauth]

        Activity

        Hide
        antoine@apache.org Antoine Levy-Lambert added a comment -

        I have the same errors using Ant + jsch + Java 1.7. I have entered a bug report in the tracker of jsch at sourceforge : https://sourceforge.net/tracker/?func=detail&aid=3605486&group_id=64920&atid=509122 . The combo jsch + java 1.7 seems to be causing the problem which is not experienced with Java 1.6.

        Show
        antoine@apache.org Antoine Levy-Lambert added a comment - I have the same errors using Ant + jsch + Java 1.7. I have entered a bug report in the tracker of jsch at sourceforge : https://sourceforge.net/tracker/?func=detail&aid=3605486&group_id=64920&atid=509122 . The combo jsch + java 1.7 seems to be causing the problem which is not experienced with Java 1.6.
        Hide
        maartenc Maarten Coene added a comment -

        Duplicate of IVY-1408?
        Could you try again with trunk version of Ivy?

        Show
        maartenc Maarten Coene added a comment - Duplicate of IVY-1408 ? Could you try again with trunk version of Ivy?
        Hide
        antoine@apache.org Antoine Levy-Lambert added a comment -


        Atsuhiko Yamanaka wrote : It seems JCE included in Java7u6(and later) has suddenly changed its behavior. Please try following version, http://jcraft.com/jsch/jsch-0.1.50-rc1.zip We have confirmed this version can make 10,000 connections without "verify: false" errors on Java7u15.

        Show
        antoine@apache.org Antoine Levy-Lambert added a comment - Atsuhiko Yamanaka wrote : It seems JCE included in Java7u6(and later) has suddenly changed its behavior. Please try following version, http://jcraft.com/jsch/jsch-0.1.50-rc1.zip We have confirmed this version can make 10,000 connections without "verify: false" errors on Java7u15.

          People

          • Assignee:
            maartenc Maarten Coene
            Reporter:
            simijskes Simon IJskes
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development