Uploaded image for project: 'Ivy'
  1. Ivy
  2. IVY-1334

Ivy buildnumber task use wrong URL to access Artifactory repository

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None
    • Environment:

      Windows

      Description

      I run "ant publish -v" and get the error message.

      [ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
      [ivy:buildnumber] problem while listing resources in http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/ with pubRep:
      [ivy:buildnumber] java.io.IOException The HTTP response code for http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/ did not indicate a success. See log for more detail.
      [ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
      [ivy:buildnumber] problem while listing resources in http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/ with pubRep:
      [ivy:buildnumber] java.io.IOException The HTTP response code for http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/ did not indicate a success. See log for more detail

      I assume the correct behavior should be accessing "http://maven.ph.co.nz/libs-releases/nz/co/uconnect/flo2cash/"

      My setting is:
      <url name="pubRep">
      <artifact pattern="http://maven.ph.co.nz/libs-releases/[organisation]/[module]/[revision]/[artifact][revision]([classifier]).[ext]" />
      <ivy pattern="http://maven.ph.co.nz/libs-releases/[organisation]/[module]/[revision]/ivy.xml" />
      </url>

        Activity

        ganzhi James Gan added a comment -

        Solved by using useMavenMetadata="false" option.

        <ibiblio name="pubRep" m2compatible="true" root="http://maven.propellerhead.co.nz/libs-releases-local" useMavenMetadata="false"/>

        ganzhi James Gan added a comment -

        Can we let buildnumber task ignores maven-metadata.xml ?

        ganzhi James Gan added a comment -

        Can we change setting of Ivy so it ignores "maven-metadata.xml" when buildnumber task is executed?

        ganzhi James Gan added a comment -

        Maarten,

        I've tried m2compatible option. The problem is that "maven-metadata.xml" file is not generated when I publish artifacts to Artifactory repository with Ivy. Thus the buildnumber is never correct since it depends on maven-metadata.xml. Is there a way to force Ivy to generate and upload "maven-metadata.xml"?

        Thanks!

        maartenc Maarten Coene added a comment -

        If your repository has a maven2 layout you should set the m2compatible='true' flag:

        <url name="pubRep" m2compatible="true">
        ...
        </url>


          People

          • Assignee:
            Unassigned
            Reporter:
            ganzhi James Gan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development