Ivy
  1. Ivy
  2. IVY-1199

The ivy-module version used by XmlModuleDescriptorWriter is hard coded to 1.0.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.2.0-RC1
    • Component/s: None
    • Labels:
      None

      Description

      In the documentation you state that ivy-module version should be 2.0. But if you use the toIvyFile method of the DefaultModuleDescriptor is uses 1.0 as the version.

        Activity

        Hide
        Maarten Coene added a comment -

        ok, I've updated it to "2.0" by default and even "2.2" if the Ivy file has a parent (which is a new feature since 2.2)

        Show
        Maarten Coene added a comment - ok, I've updated it to "2.0" by default and even "2.2" if the Ivy file has a parent (which is a new feature since 2.2)

          People

          • Assignee:
            Maarten Coene
            Reporter:
            Hans Dockter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development