Commons IO
  1. Commons IO
  2. IO-347

commons-io:commons-io:1.3.2 POM incorrectly deployed under org.apache.commons

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      As already discussed a bit on IO-125 and related to https://issues.sonatype.org/browse/MVNCENTRAL-244:

      http://repo1.maven.org/maven2/org/apache/commons/commons-io/1.3.2/commons-io-1.3.2.pom has a incorrect groupId commons-io, Artifactory e.g. complains about this.

      AFAIS the artifacts at org/apache/commons have the same checksums as those at commons-io. As a workaround I deployed a relocation POM https://raw.github.com/gist/3832570/ac0c2503cea5e8642035eae0904fab4ad2fb74f3/commons-io-1.3.2.pom in a repository which is searched before central in my Artifactory instance.

        Issue Links

          Activity

          Sebb added a comment -

          The problem is that 1.3.2 was accidentally copied into the wrong source directory at Apache from whence it was deployed.
          [It seems Maven Central had/has no check to ensure that the coordinates and directory agree with each other]

          I've looked, and the Apache Nexus repo currently has both entries.

          I think there are two stages to fixing this:
          1) remove incorrect entry from Apache Nexus (INFRA-5359 created for this)
          2) persuade Maven Central to drop the incorrect entry.


            People

            • Assignee:
              Unassigned
              Reporter:
              Mirko Friedenhagen
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development