Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-681

Investigate memory usage in TestWideRow

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: Impala 1.2.1
    • Fix Version/s: Impala 2.9.0
    • Component/s: Backend

      Description

      The query in TestWideRow needs a mem limit of roughly 80MB (some formats require less), even though the table being scanned contains only 10MB of data. We need to figure out where exactly this memory usage is coming from, and determine if any of this usage is due to inefficiencies/bugs we should fix.

        Activity

        tarmstrong Tim Armstrong added a comment -

        I can't reproduce this - I'm seeing a peak memory of 10mb.

        dhecht Dan Hecht added a comment -

        SInce we've had to bump the mem limit a few times (latest IMPALA-3081) let's increase priority to getting to the bottom of this. And once we understand/fix it, let's consider decreasing the limit again if possible.


          People

          • Assignee:
            Unassigned
            Reporter:
            skye Skye Wanderman-Milne
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development