Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-2567 KRPC milestone 1
  3. IMPALA-5714

Openssl 1.0.0 shared library support for legacy platform

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Impala 2.10.0
    • Fix Version/s: Impala 2.10.0
    • Component/s: Infrastructure
    • Labels:
      None
    • Epic Color:
      ghx-label-9

      Description

      Currently, Impala on asf-master requires OpenSSL version 0.9.8 or above. However, with Kudu RPC, Impala will require OpenSSL version 1.0.0 or newer. Some legacy platforms such as Centos5, SLES 11 or Ubuntu 12.02 do not come equipped with the required version of OpenSSL library by default. To enable users of those platforms to build and run Impala with Kudu RPC, one option is to use the OpenSSL library in native-toolchain (e.g. by adding Impala toolchain to LD_LIBRARY_PATH).

      It appears that binaries or libraries on some Debian based distributions (e.g. Ubuntu 14.04) expect OpenSSL library to be built with version information which our toolchain build doesn't provide right now. As a result, one cannot use the shared library from native-toolchain on those platforms. Using it will result in error like the following:

      $IMPALA_HOME/be/build/latest/statestore/statestored: $IMPALA_HOME/toolchain/openssl-1.0.1p/lib/libssl.so.1.0.0: no version information available (required by $IMPALA_HOME/toolchain/kudu-1070e76/debug/lib/libkudu_client.so.0)
      

        Attachments

          Activity

            People

            • Assignee:
              kwho Michael Ho
              Reporter:
              kwho Michael Ho
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: