Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5337

DITA not including anchor for "concepts"

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • Impala 2.8.0
    • Impala 3.1.0
    • Docs
    • None

    Description

      Some links in Impala HTML documentation contain anchors, but it seems like anchors are not being written into the rendered documentation.

      To reproduce shorthand, see that http://impala.apache.org/docs/build/html/topics/impala_fixed_issues.html#fixed_issues_101 does not follow any anchor but just opens at the top of the page.

      For a "valid user experience",

      1. Go to http://impala.apache.org/docs/build/html/topics/impala_new_features.html
      2. Find "New Features in Impala 1.0.1"
      3. Click "See Issues Fixed in the 1.0.1 Release for details" and see that the browser doesn't find any anchor, and the page remains at the top

      From original source impala_fixed_issues.xml:

        <concept id="fixed_issues_101">
      
          <title>Issues Fixed in the 1.0.1 Release</title>
      

      Rendered source, missing <a name>:

        <article class="topic concept nested1" aria-labelledby="ariaid-title296" id="fixed_issues__fixed_issues_101">
      
          <h2 class="title topictitle2" id="ariaid-title296">Issues Fixed in the 1.0.1 Release</h2>
      
          <div class="body conbody">
      

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            arodoni Alexandra Rodoni
            mikeb Michael Brown
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment