Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5305

query_test/test_observability.py failing on s3, localFS and Isilon after recent changes to test data

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: None
    • Labels:
    • Epic Color:
      ghx-label-9

      Description

      After recent changes to our test data, this test started failing on all of the "non-standard" storage locations (s3, local FS, and Isilon.)

      04:20:33 =================================== FAILURES ===================================
      04:20:33 _____________________ TestObservability.test_scan_summary ______________________
      04:20:33 [gw2] linux2 -- Python 2.6.6 /data/jenkins/workspace/impala-umbrella-build-and-test/repos/Impala/bin/../infra/python/env/bin/python
      04:20:33 query_test/test_observability.py:72: in test_scan_summary
      04:20:33     result = self.execute_query(query)
      04:20:33 common/impala_test_suite.py:487: in wrapper
      04:20:33     return function(*args, **kwargs)
      04:20:33 common/impala_test_suite.py:535: in execute_query
      04:20:33     return self.__execute_query(self.client, query, query_options)
      04:20:33 common/impala_test_suite.py:602: in __execute_query
      04:20:33     return impalad_client.execute(query, user=user)
      04:20:33 common/impala_connection.py:160: in execute
      04:20:33     return self.__beeswax_client.execute(sql_stmt, user=user)
      04:20:33 beeswax/impala_beeswax.py:173: in execute
      04:20:33     handle = self.__execute_query(query_string.strip(), user=user)
      04:20:33 beeswax/impala_beeswax.py:337: in __execute_query
      04:20:33     handle = self.execute_query_async(query_string, user=user)
      04:20:33 beeswax/impala_beeswax.py:333: in execute_query_async
      04:20:33     return self.__do_rpc(lambda: self.imp_service.query(query,))
      04:20:33 beeswax/impala_beeswax.py:458: in __do_rpc
      04:20:33     raise ImpalaBeeswaxException(self.__build_error_message(b), b)
      04:20:33 E   ImpalaBeeswaxException: ImpalaBeeswaxException:
      04:20:33 E    INNER EXCEPTION: <class 'beeswaxd.ttypes.BeeswaxException'>
      04:20:33 E    MESSAGE: RuntimeException: couldn't retrieve HBase table (functional_hbase.alltypestiny) info:
      04:20:33 E   Enable/Disable failed
      04:20:33 E   CAUSED BY: IOException: Enable/Disable failed
      04:20:33 E   CAUSED BY: ConnectionLossException: KeeperErrorCode = ConnectionLoss for /hbase/table/functional_hbase.alltypestiny
      04:20:33 ----------------------------- Captured stderr call -----------------------------
      04:20:33 -- executing against localhost:21000
      04:20:33 select count(*) from functional.alltypestiny;
      04:20:33 
      04:20:33 -- executing against localhost:21000
      04:20:33 select count(*) from functional_kudu.alltypestiny;
      04:20:33 
      04:20:33 -- executing against localhost:21000
      04:20:33 select count(*) from functional_hbase.alltypestiny;
      04:20:33 
      04:20:33 ======= 1 failed, 1293 passed, 168 skipped, 7 xfailed in 3105.04 seconds =======
      04:20:33 ============================= test session starts ==============================
      

        Activity

        twmarshall Thomas Tauber-Marshall added a comment -

        commit f195b7577c268b794180da50b1f3aaf01304f3a1
        Author: Thomas Tauber-Marshall <tmarshall@cloudera.com>
        Date: Thu May 11 11:57:09 2017 -0700

        IMPALA-5305: test_observability.py failing on s3, localFS and Isilon

        A test that was recently added, test_observability::test_scan_summary,
        uses an HBase table. It needs to be restricted not to run on S3,
        localFS or Isilon.

        Change-Id: I9863cf3f885eb1d2152186de34e093497af83d99
        Reviewed-on: http://gerrit.cloudera.org:8080/6859
        Reviewed-by: Alex Behm <alex.behm@cloudera.com>
        Reviewed-by: Matthew Jacobs <mj@cloudera.com>
        Reviewed-by: Thomas Tauber-Marshall <tmarshall@cloudera.com>
        Tested-by: Impala Public Jenkins

        dknupp David Knupp added a comment -

        Thanks Thomas Tauber-Marshall – didn't spend much time.

        twmarshall Thomas Tauber-Marshall added a comment -

        David Knupp sorry if you spent time looking into this, there's already a solution GVOing: https://gerrit.cloudera.org/#/c/6859/

        dknupp David Knupp added a comment -

        Probably it's something to do with this commit:
        https://github.com/apache/incubator-impala/commit/49b6af5


          People

          • Assignee:
            twmarshall Thomas Tauber-Marshall
            Reporter:
            dknupp David Knupp
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development