Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5244

data_errors/test_data_errors.py:56: in test_hdfs_file_open_fail on local filesystem build

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: Backend
    • Labels:
    • Epic Color:
      ghx-label-7

      Description

      Looks like recent modification to TestHdfsFileOpenFailErrors failed on local filesystem build. May be this test needs to be skipped on local filesystem builds ?

      04:11:01 =========================== short test summary info ============================
      04:11:01 FAIL data_errors/test_data_errors.py::TestHdfsFileOpenFailErrors::()::test_hdfs_file_open_fail
      04:11:01 =================================== FAILURES ===================================
      04:11:01 _____________ TestHdfsFileOpenFailErrors.test_hdfs_file_open_fail ______________
      04:11:01 data_errors/test_data_errors.py:56: in test_hdfs_file_open_fail
      04:11:01     self.client.execute(create_stmt)
      04:11:01 common/impala_connection.py:160: in execute
      04:11:01     return self.__beeswax_client.execute(sql_stmt, user=user)
      04:11:01 beeswax/impala_beeswax.py:173: in execute
      04:11:01     handle = self.__execute_query(query_string.strip(), user=user)
      04:11:01 beeswax/impala_beeswax.py:337: in __execute_query
      04:11:01     handle = self.execute_query_async(query_string, user=user)
      04:11:01 beeswax/impala_beeswax.py:333: in execute_query_async
      04:11:01     return self.__do_rpc(lambda: self.imp_service.query(query,))
      04:11:01 beeswax/impala_beeswax.py:458: in __do_rpc
      04:11:01     raise ImpalaBeeswaxException(self.__build_error_message(b), b)
      04:11:01 E   ImpalaBeeswaxException: ImpalaBeeswaxException:
      04:11:01 E    INNER EXCEPTION: <class 'beeswaxd.ttypes.BeeswaxException'>
      04:11:01 E    MESSAGE: ImpalaRuntimeException: Error making 'createTable' RPC to Hive Metastore: 
      04:11:01 E   CAUSED BY: MetaException: file:/test-warehouse/file_open_fail is not a directory or unable to create one
      04:11:01 =============== 1650 tests deselected by "-m 'execute_serially'" ===============
      04:11:01 ===== 1 failed, 88 passed, 86 skipped, 1650 deselected in 2512.49 seconds ======
      04:11:01 MainThread: Found 1 impalad/1 statestored/1 catalogd process(es)
      04:11:01 >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
      

        Activity

        dhecht Dan Hecht added a comment -

        commit edcc593ee541bb2677d58e31fe713f2cb4951937
        Author: Sailesh Mukil <sailesh@cloudera.com>
        Date: Mon Apr 24 23:22:37 2017 -0700

        IMPALA-5244 test_hdfs_file_open_fail fails on local filesystem build

        This test had to be skipped for non HDFS filesystems.

        Change-Id: I5318a5eb27b15fed5df770b9c3ea23e7e1a97a4c
        Reviewed-on: http://gerrit.cloudera.org:8080/6723
        Reviewed-by: Michael Ho <kwho@cloudera.com>
        Reviewed-by: Sailesh Mukil <sailesh@cloudera.com>
        Tested-by: Impala Public Jenkins


          People

          • Assignee:
            sailesh Sailesh Mukil
            Reporter:
            kwho Michael Ho
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development