Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5177

Error making alter_table rpc, job failure

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Impala 2.8.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: Catalog
    • Labels:
    • Epic Color:
      ghx-label-8

      Description

      20:54:13 FAIL data_errors/test_data_errors.py::TestTimestampErrors::()::test_timestamp_scan_agg_errors[exec_option: {'disable_codegen': False, 'abort_on_error': 1, 'exec_single_node_rows_threshold': 0, 'batch_size': 1, 'num_nodes': 0} | table_format: text/none]
      20:54:13 =================================== FAILURES ===================================
      20:54:13  TestTimestampErrors.test_timestamp_scan_agg_errors[exec_option: {'disable_codegen': False, 'abort_on_error': 1, 'exec_single_node_rows_threshold': 0, 'batch_size': 1, 'num_nodes': 0} | table_format: text/none] 
      20:54:13 [gw1] linux2 -- Python 2.6.6 /data/jenkins/workspace/impala-umbrella-build-and-test/repos/Impala/bin/../infra/python/env/bin/python
      20:54:13 data_errors/test_data_errors.py:152: in test_timestamp_scan_agg_errors
      20:54:13     self._setup_test_table(FQ_TBL_NAME)
      20:54:13 data_errors/test_data_errors.py:148: in _setup_test_table
      20:54:13     self.client.execute(alter_stmt)
      20:54:13 common/impala_connection.py:160: in execute
      20:54:13     return self.__beeswax_client.execute(sql_stmt, user=user)
      20:54:13 beeswax/impala_beeswax.py:173: in execute
      20:54:13     handle = self.__execute_query(query_string.strip(), user=user)
      20:54:13 beeswax/impala_beeswax.py:337: in __execute_query
      20:54:13     handle = self.execute_query_async(query_string, user=user)
      20:54:13 beeswax/impala_beeswax.py:333: in execute_query_async
      20:54:13     return self.__do_rpc(lambda: self.imp_service.query(query,))
      20:54:13 beeswax/impala_beeswax.py:458: in __do_rpc
      20:54:13     raise ImpalaBeeswaxException(self.__build_error_message(b), b)
      20:54:13 E   ImpalaBeeswaxException: ImpalaBeeswaxException:
      20:54:13 E    INNER EXCEPTION: <class 'beeswaxd.ttypes.BeeswaxException'>
      20:54:13 E    MESSAGE: 
      20:54:13 E   ImpalaRuntimeException: Error making 'alter_table' RPC to Hive Metastore: 
      20:54:13 E   CAUSED BY: MetaException: Exception thrown when executing query
      

      Looks like there is something failing in the Hive rpc.

      1. hms.log
        24 kB
        Dimitris Tsirogiannis

        Issue Links

          Activity

          dtsirogiannis Dimitris Tsirogiannis added a comment -

          Closing this since the Hive JIRA which it is blocked on has been resolved.

          jbapple Jim Apple added a comment -

          As a reminder, CDH-52473 is not an Apache Impala ticket, yet this is the Apache Impala bugtracker.

          dtsirogiannis Dimitris Tsirogiannis added a comment -

          This looks like an HMS issue from the logs (attached). Filed CDH-52473.


            People

            • Assignee:
              dtsirogiannis Dimitris Tsirogiannis
              Reporter:
              mjacobs Matthew Jacobs
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development