We should clean-up the profile counters that are added to each node so that irrelevant info is hidden and relevant info is easy to find:
- Hide the limit if it is MAX_INT64
- Remove the BufferPool prefix and move into a "Buffer pool" section, or similar
- Remove or rename potentially confusing counters, e.g.
- the cumulative allocation counters should be removed or renamed to be clearer that they are cumulative
- PeakUnpinnedBytes is confusing unless you understand the internals