Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5076

query_test.test_exprs.TestExprs.test_exprs fails on SLES12 SP2

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: None
    • Labels:
      None
    • Epic Color:
      ghx-label-2

      Description

      This runs successfully against a cluster installed with Ubuntu, Centos, Redhat, Debian, and Oracle. However, it fails on SLES12 cluster with the following error:

      Stacktrace:

      query_test/test_exprs.py:58: in test_exprs
          self.run_test_case('QueryTest/exprs', vector)
      common/impala_test_suite.py:388: in run_test_case
          self.__verify_results_and_errors(vector, test_section, result, use_db)
      common/impala_test_suite.py:273: in __verify_results_and_errors
          replace_filenames_with_placeholder)
      common/test_result_verifier.py:317: in verify_raw_results
          verify_errors(expected_errors, actual_errors)
      common/test_result_verifier.py:274: in verify_errors
          VERIFIER_MAP['VERIFY_IS_EQUAL'](expected, actual)
      common/test_result_verifier.py:231: in verify_query_result_is_equal
          assert expected_results == actual_results
      E   assert Comparing QueryTestResults (expected vs actual):
      E     'UDF WARNING: Cannot add interval 1: Year is out of valid range: 1400..9999' != None
      E     Number of rows returned (expected vs actual): 1 != 0
      

        Activity

        dknupp David Knupp added a comment - - edited

        Query that failed:

        -- executing against <impalad_host>:21000
        select CAST('9999-12-31 21:00:00' AS TIMESTAMP) + INTERVAL 1 DAYS
        from alltypes
        limit 1;
        
        MainThread: Comparing QueryTestResults (expected vs actual):
        'UDF WARNING: Cannot add interval 1: Year is out of valid range: 1400..9999' != None
        Number of rows returned (expected vs actual): 1 != 0
        
        dknupp David Knupp added a comment -

        It's possible this was caused by incorrect test data. The data in the test warehouse was updated, and the tests passed. I will resolve this for now, but will still keep an eye on future tests on this build.


          People

          • Assignee:
            Unassigned
            Reporter:
            dknupp David Knupp
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development