Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-5074

query_test.test_aggregation.TestAggregationQueries.test_aggregation fails on SLES12 SP2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: None
    • Labels:
      None
    • Epic Color:
      ghx-label-9

      Description

      Stacktrace:

      This runs successfully on Ubuntu, Centos, Redhat, Debian, and Oracle. However, it fails on SLES12 with the following error:

      query_test/test_aggregation.py:203: in test_aggregation
          self.run_test_case('QueryTest/aggregation', vector)
      common/impala_test_suite.py:388: in run_test_case
          self.__verify_results_and_errors(vector, test_section, result, use_db)
      common/impala_test_suite.py:273: in __verify_results_and_errors
          replace_filenames_with_placeholder)
      common/test_result_verifier.py:404: in verify_raw_results
          VERIFIER_MAP[verifier](expected, actual)
      common/test_result_verifier.py:231: in verify_query_result_is_equal
          assert expected_results == actual_results
      E   assert Comparing QueryTestResults (expected vs actual):
      E     NULL,NULL,0,NULL,NULL,0 != 0,0,0,0,0,0
      

        Activity

        dknupp David Knupp added a comment -

        Failing query:

        SELECT variance(tinyint_col), variance_samp(smallint_col), variance_pop(int_col),
        stddev(smallint_col), stddev_samp(smallint_col), stddev_pop(bigint_col)
        from alltypesagg WHERE id = 1006;
        
        MainThread: Comparing QueryTestResults (expected vs actual):
        NULL,NULL,0,NULL,NULL,0 != 0,0,0,0,0,0
        
        dknupp David Knupp added a comment -

        It's possible this was caused by incorrect test data. The data in the test warehouse was updated, and the tests passed. I will close this for now, but will still keep an eye on future tests on this build.


          People

          • Assignee:
            Unassigned
            Reporter:
            dknupp David Knupp
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development