Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-4941

Bump Zookeeper version to 3.4.10 to address ZOOKEEPER-2044

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: Infrastructure
    • Labels:
      None

      Description

      ZOOKEEPER-2044 fixes the root cause of IMPALA-4733. The fix is included in Zookeeper version 3.4.10, we need to bump the minicluster dependency.

      David Knupp - Do you know how or where to change this version?

        Activity

        lv Lars Volker added a comment -

        After talking to the team that builds the zookeeper artifacts I'm confident that the backport has arrived in our dependency, so I'm closing this.

        lv Lars Volker added a comment -

        Impala pulls zookeeper from this URL: https://repository.cloudera.com/content/repositories/snapshots/org/apache/zookeeper/zookeeper/3.4.5-cdh5.11.0-SNAPSHOT

        I pinged the team working on Zookeeper at Cloudera and they will backport ZOOKEEPER-2044. I'll update this JIRA with any progress.

        alex.behm Alexander Behm added a comment -

        You can run "mvn dependency:tree" from the IMPALA_HOME/fe directory to see our tree of dependencies.

        Long story short, we don't depend on Zookeeper directly, but we pull in the dependency transitively.

        dknupp David Knupp added a comment -

        Here are all the places it shows up. I don't know much about it, but it looks like it's not even a "top level" CDH component in the toolchain. It's included in Hbase, Hive, etc.

        ./toolchain/cdh_components/hive-1.1.0-cdh5.11.0-SNAPSHOT/lib/zookeeper-3.4.5-cdh5.11.0-20161214.154236-18.jar
        ./toolchain/cdh_components/hbase-1.2.0-cdh5.11.0-SNAPSHOT/lib/zookeeper-3.4.5-cdh5.11.0-SNAPSHOT.jar
        ./toolchain/cdh_components/hadoop-2.6.0-cdh5.11.0-SNAPSHOT/share/hadoop/yarn/lib/zookeeper-3.4.5-cdh5.11.0-SNAPSHOT.jar
        ./toolchain/cdh_components/hadoop-2.6.0-cdh5.11.0-SNAPSHOT/share/hadoop/common/lib/zookeeper-3.4.5-cdh5.11.0-20161216.130726-20.jar
        ./toolchain/cdh_components/hadoop-2.6.0-cdh5.11.0-SNAPSHOT/share/hadoop/tools/lib/zookeeper-3.4.5-cdh5.11.0-20161216.130726-20.jar
        ./toolchain/cdh_components/hadoop-2.6.0-cdh5.11.0-SNAPSHOT/share/hadoop/kms/tomcat/webapps/kms/WEB-INF/lib/zookeeper-3.4.5-cdh5.11.0-20161216.130726-20.jar
        ./toolchain/cdh_components/hadoop-2.6.0-cdh5.11.0-SNAPSHOT/share/hadoop/httpfs/tomcat/webapps/webhdfs/WEB-INF/lib/zookeeper-3.4.5-cdh5.11.0-20161216.130726-20.jar
        ./toolchain/cdh_components/sentry-1.5.1-cdh5.11.0-SNAPSHOT/lib/zookeeper-3.4.5-cdh5.11.0-20161214.154236-18.jar
        ./testdata/target/dependency/zookeeper-3.4.5-cdh5.11.0-SNAPSHOT.jar
        ./fe/target/dependency/zookeeper-3.4.5-cdh5.11.0-SNAPSHOT.jar
        
        dknupp David Knupp added a comment -

        Lars Volker I'm not sure how to do this either.


          People

          • Assignee:
            lv Lars Volker
            Reporter:
            lv Lars Volker
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development