Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-49

Remove libjvm dependency from statestored

    XMLWordPrintableJSON

    Details

      Description

      statestored currently depends on libjvm. I think this is because it has all the link dependencies as impalad.

      We have a wrapper script as part of the package for starting up impalad with the proper java version but no such script for statestored. This is problematic on deployments where the java install is atypical (e.g. they have java6 and java7 installed). We can fix this by removing the statestored's libjvm dependency.

        Attachments

          Activity

            People

            • Assignee:
              henryr Henry Robinson
              Reporter:
              nong_impala_60e1 Nong Li
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: