Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-4897

AnalysisException: specified cache pool does not exist

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: Frontend
    • Labels:

      Description

      I have seen this test fail with Change-Id: I0baf14d6f0466d11539c5ada1a1cc1ab7ca11cd6 and Change-Id: I175b32dd9031e51218b38c37693ac3e31dfab47b.

       TestDdlStatements.test_alter_table[exec_option: {'batch_size': 0, 'num_nodes': 0, 'sync_ddl': 0, 'disable_codegen': False, 'abort_on_error': 1, 'exec_single_node_rows_threshold': 0} | table_format: text/none-unique_database0] 
      [gw0] linux2 -- Python 2.6.6 /data/jenkins/workspace/impala-umbrella-build-and-test-isilon/repos/Impala/bin/../infra/python/env/bin/python
      metadata/test_ddl.py:255: in test_alter_table
          multiple_impalad=self._use_multiple_impalad(vector))
      common/impala_test_suite.py:359: in run_test_case
          result = self.__execute_query(target_impalad_client, query, user=user)
      common/impala_test_suite.py:567: in __execute_query
          return impalad_client.execute(query, user=user)
      common/impala_connection.py:160: in execute
          return self.__beeswax_client.execute(sql_stmt, user=user)
      beeswax/impala_beeswax.py:173: in execute
          handle = self.__execute_query(query_string.strip(), user=user)
      beeswax/impala_beeswax.py:337: in __execute_query
          handle = self.execute_query_async(query_string, user=user)
      beeswax/impala_beeswax.py:333: in execute_query_async
          return self.__do_rpc(lambda: self.imp_service.query(query,))
      beeswax/impala_beeswax.py:458: in __do_rpc
          raise ImpalaBeeswaxException(self.__build_error_message(b), b)
      E   ImpalaBeeswaxException: ImpalaBeeswaxException:
      E    INNER EXCEPTION: <class 'beeswaxd.ttypes.BeeswaxException'>
      E    MESSAGE: AnalysisException: The specified cache pool does not exist: testPool
      

        Activity

        jbapple Jim Apple added a comment -

        I've seen this fail on s3, now, too

        dtsirogiannis Dimitris Tsirogiannis added a comment -

        Ok, I believe I know what the problem is. In general, tests with statements that use hdfs caching should be skipped from S3 and Isilon runs. The patch for IMPALA-1670 (commit c452595, 6 days ago) added a number of test cases in test_alter_table that use hdfs caching; this test runs in almost all the file systems. Attila Jeges, I am assigning this to you.

        sailesh Sailesh Mukil added a comment -

        Since this needs to get in quickly, I can put out a patch now so it doesn't break through the weekend.

        sailesh Sailesh Mukil added a comment -

        This seems like it'll take a little longer than I thought it would. I'll try to put the patch out asap.

        jbapple Jim Apple added a comment -

        Patch has been +2ed, but failed pre-merge testing:

        https://gerrit.cloudera.org/#/c/5972/


          People

          • Assignee:
            sailesh Sailesh Mukil
            Reporter:
            jbapple Jim Apple
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development