Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-4868

TestRequestPoolService.testUpdatingConfigs fails: "checkModifiedConfigResults:245 expected:<root.queueC> but was:<null>"

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.9.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: Frontend
    • Labels:

      Description

      TestRequestPoolService.testUpdatingConfigs fails with the error below.

      Matthew Jacobs - I’m assigning this to you thinking you might have an idea what’s going on here; feel free to find another person or assign back to me if you're swamped.

      14:43:48 Tests run: 9, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 7.313 sec <<< FAILURE! - in org.apache.impala.util.TestRequestPoolService
      14:43:48 testUpdatingConfigs(org.apache.impala.util.TestRequestPoolService)  Time elapsed: 7.116 sec  <<< FAILURE!
      14:43:48 	at org.apache.impala.util.TestRequestPoolService.checkModifiedConfigResults(TestRequestPoolService.java:245)
      14:43:48 	at org.apache.impala.util.TestRequestPoolService.testUpdatingConfigs(TestRequestPoolService.java:206)
      
      ...
      
      14:43:48   TestRequestPoolService.testUpdatingConfigs:206->checkModifiedConfigResults:245 expected:<root.queueC> but was:<null>
      14:43:48 Tests run: 564, Failures: 1, Errors: 0, Skipped: 20
      14:43:48 [INFO] BUILD FAILURE
      14:43:48 [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.18:test (default-test) on project impala-frontend: There are test failures.
      14:43:48 [ERROR] 
      14:43:48 [ERROR] Please refer to /data/jenkins/workspace/impala-umbrella-build-and-test/repos/Impala/logs/fe_tests for the individual test results.
      14:43:48 [ERROR] -> [Help 1]
      14:43:48 [ERROR] 
      14:43:48 [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      14:43:48 [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      14:43:48 [ERROR] 
      14:43:48 [ERROR] For more information about the errors and possible solutions, please read the following articles:
      14:43:48 [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
      14:43:48 mvn -fae test exited with code 0
      

        Issue Links

          Activity

          mjacobs Matthew Jacobs added a comment -

          The test has been disabled. I opened IMPALA-5687 to track re-enabling the test later.

          mjacobs Matthew Jacobs added a comment -

          Disabled in this commit:

          commit 34d9a79c599950fd06ea53cce157994b265a97eb
          Author: Matthew Jacobs <mj@cloudera.com>
          Date: Wed Jul 19 16:52:13 2017 -0700

          IMPALA-4868: Disable flaky TestRequestPoolService test

          Disables a test that seemed to get flaky recently, perhaps
          related to testing with Java 8 or maybe even changes in YARN
          (which get used by RequestPoolService).

          Since we're not changing this code right now, let's disable
          this test to unblock builds. Keeping the JIRA open to track
          a better solution.

          Change-Id: I616961457cd48d31d618c8b58f5279b89d3cdcd6
          Reviewed-on: http://gerrit.cloudera.org:8080/7466
          Reviewed-by: Matthew Jacobs <mj@cloudera.com>
          Tested-by: Impala Public Jenkins

          dknupp David Knupp added a comment -

          Oh shoot! Sorry – I misread that! I thought you meant disable the job. Oops. In that case, please feel free to submit that patch.

          mjacobs Matthew Jacobs added a comment -

          David Knupp does that mean you'll submit the patch to disable ? No worries if you don't have time.

          dknupp David Knupp added a comment -

          > It's probably worth disabling this test for now

          Done.

          mjacobs Matthew Jacobs added a comment -

          Hm, that's interesting. It's probably worth disabling this test for now because I haven't been able to track down the cause of the failures and this code isn't changing right now, so I don't think it's worth the productivity hit of having a flaky test.

          dknupp David Knupp added a comment -

          Note that this failure started to appear after we upgraded the impala-setup scripts to install Oracle JDK 8 rather than 7. It doesn't seem to fail every time though.

          twmarshall Thomas Tauber-Marshall added a comment -

          Seen again in a Jenkins run

          mjacobs Matthew Jacobs added a comment -

          266cd53c1ccd5a0dcfbcf2c26d98e5e561c2fae5

          mjacobs Matthew Jacobs added a comment -

          3b36e939c0b18d79be079da79881865e83e4bdb2

          lv Lars Volker added a comment -

          I’ve seen this happen in a private Jenkins run. Please ping me if you would like access to the build artifacts.


            People

            • Assignee:
              mjacobs Matthew Jacobs
              Reporter:
              lv Lars Volker
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development