Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-4590

Kudu test failure; several error messages changed

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Impala 2.8.0
    • Fix Version/s: Impala 2.8.0
    • Component/s: Infrastructure
    • Labels:

      Description

      Several error messages changed which break Impala tests.

      For example:

      13:57:01 -- Test range partitioning with overlapping partitions
      13:57:01 create table simple_range_with_overlapping (id int, name string, valf float, vali bigint,
      13:57:01   primary key (id, name)) distribute by range (id)
      13:57:01   (partition values <= 10, partition values < 20, partition value = 5) stored as kudu;
      
      13:57:01 [gw0] linux2 -- Python 2.6.6 /data/jenkins/workspace/impala-umbrella-build-and-test/repos/Impala/bin/../infra/python/env/bin/python
      13:57:01 query_test/test_kudu.py:59: in test_kudu_partition_ddl
      13:57:01     self.run_test_case('QueryTest/kudu_partition_ddl', vector, use_db=unique_database)
      13:57:01 common/impala_test_suite.py:327: in run_test_case
      13:57:01     self.__verify_exceptions(test_section['CATCH'], str(e), use_db)
      13:57:01 common/impala_test_suite.py:218: in __verify_exceptions
      13:57:01     (expected_str, actual_str)
      13:57:01 E   AssertionError: Unexpected exception string. Expected: NonRecoverableException: overlapping range partitions: first range partition: [<start>, (int32 id=11)), second range partition: [<start>, (int32 id=20))
      13:57:01 E   Not found in actual: ImpalaBeeswaxException: INNER EXCEPTION: <class 'beeswaxd.ttypes.BeeswaxException'> MESSAGE: ImpalaRuntimeException: Error creating Kudu table 'impala::test_kudu_partition_ddl_13aebfc6.simple_range_with_overlapping'CAUSED BY: NonRecoverableException: overlapping range partitions: first range partition: VALUES < 11, second range partition: VALUES < 20
      

      There is also a change to :

      13:57:01 E   AssertionError: Unexpected exception string. Expected: NonRecoverableException: Key column may not have type of BOOL, FLOAT, or DOUBLE
      13:57:01 E   Not found in actual: ImpalaBeeswaxException: INNER EXCEPTION: <class 'beeswaxd.ttypes.BeeswaxException'> MESSAGE: ImpalaRuntimeException: Error creating Kudu table 'impala::test_create_kudu_50fff6f8.tab'CAUSED BY: NonRecoverableException: key column may not have type of BOOL, FLOAT, or DOUBLE
      

      Testing w/ native-toolchain & build:
      IMPALA_TOOLCHAIN_BUILD_ID=289-f12b0dd2e9
      IMPALA_KUDU_VERSION=60aa54e

      Updating the toolchain to the above version will be blocked on this.

        Activity

        mjacobs Matthew Jacobs added a comment -

        commit 5188f879a7940f96dcaf3892f08c0aa76f58abe2
        Author: Matthew Jacobs <mj@cloudera.com>
        Date: Sat Dec 3 09:58:20 2016 -0800

        IMPALA-4477: Bump Kudu version to latest master (60aa54e)

        Bumps the toolchain version to get a newer Kudu build.

        Also fixes test failures resulting from changes in Kudu.
        Notably error strings have changed (IMPALA-4590) and the
        number of replicas must be odd (IMPALA-4589).

        Note: The toolchain binaries starting with this build are
        now using the toolchain binutils rather than the system
        binutils.

        Testing: private exhaustive build.

        Change-Id: If1912f058c240fbe82b06f77e31add7755289be1
        Reviewed-on: http://gerrit.cloudera.org:8080/5369
        Reviewed-by: Matthew Jacobs <mj@cloudera.com>
        Tested-by: Internal Jenkins


          People

          • Assignee:
            mjacobs Matthew Jacobs
            Reporter:
            mjacobs Matthew Jacobs
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development