Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Impala 2.8.0
    • Fix Version/s: Impala 2.9.0
    • Component/s: Backend
    • Labels:
      None

      Description

      We have a bunch of unit tests for BufferedBlockMgr, some of which are regression tests for interesting scenarios. We should go through and evaluate which of them are applicable to the new BufferPool and port those.

        Activity

        tarmstrong Tim Armstrong added a comment -

        IMPALA-4114: Port BufferedBlockMgr tests to buffer pool

        BufferedBlockMgr had a number of interesting backend tests
        that are still relevant to BufferPool. This commit copies
        them across and adapts them to BufferPool. This should bring
        the backend test coverage for BufferPool up to par with
        BufferedBlockMgr.

        Many tests weren't ported because they are not relevant or would
        duplicate other tests:

        • GetNewBlock* -> covered by PageCreation/BufferAllocation
        • Pin -> covered by Pin
        • Deletion/DeleteSingleBlocks -> all BufferPool tests cover deletion
        • Close -> BufferPool doesn't have "cancellation"
        • TransferBufferDuringWrite -> the API being tested is not present. Some
          of the deletion tests are the closest analogue.
        • WriteCompleteWithCancelledRuntimeState -> not relevant, BufferPool
          doesn't reference RuntimeState.
        • MultipleClients* -> we have many tests for the (very different)
          reservation mechanism
        • ClientOversubscription -> oversubscription is not supported
        • CreateDestroyMulti -> we don't support creation/destruction of
          buffer pools like this
        • AllocationErrorHandling -> redundant with WriteErrorBlacklist

        Change-Id: Ifb0221e8bea6f3b23b62d5094634d97562295ea3
        Reviewed-on: http://gerrit.cloudera.org:8080/6498
        Reviewed-by: Tim Armstrong <tarmstrong@cloudera.com>
        Tested-by: Impala Public Jenkins


          People

          • Assignee:
            tarmstrong Tim Armstrong
            Reporter:
            tarmstrong Tim Armstrong
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development