Details
-
Task
-
Status: Resolved
-
Major
-
Resolution: Fixed
-
3.0.0-alpha2
-
None
-
Docs Required, Release Notes Required
Description
Current version of the Table API is a little confusing and inconsistent. Need to make the following changes:
- Remove RecordView and KeyValueBinaryView interfaces.
- Rename TableView to RecordView.
- Remove extends TableView<Tuple> from the Table interface.
- Change the return type of Table#kvView() to KeyValueView<Tuple>.
- Add new method to the Table interface: RecordView<Tuple> recordView();