Uploaded image for project: 'Ignite'
  1. Ignite
  2. IGNITE-12531

Cluster is unable to change BLT on 2.8 if storage was initially created on 2.7 or less

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.8
    • Fix Version/s: 2.8
    • Component/s: None
    • Labels:
      None

      Description

      Due to bug in https://issues.apache.org/jira/browse/IGNITE-10348, after storage migration from 2.7- to 2.8 any updates of metastorage are not persisted.

      S2R:
      (on 2.7)

      • Activate persistent cluster with 2 nodes
      • Shutdown the cluster

      (on 2.8)

      • Start cluster with 2 nodes based on persistent storage from 2.7
      • Start 3rd node
      • Change baseline
      • Shutdown the cluster
      • Start initial two nodes
      • Start 3rd node (join is rejected: first two nodes has old BLT of two nodes, 3rd node has new BLT of three nodes)

      Reproducer is attached.

        Attachments

        1. TestBltChangeFail.java
          3 kB
          Ivan Rakov

          Issue Links

            Activity

              People

              • Assignee:
                slava.koptilin Vyacheslav Koptilin
                Reporter:
                ivan.glukos Ivan Rakov
                Reviewer:
                Ivan Rakov
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m