Uploaded image for project: 'Apache Hop (incubating)'
  1. Apache Hop (incubating)
  2. HOP-3292

Align apache commons lang3 library versions

    XMLWordPrintableJSON

Details

    Description

      We're building with different versions of a.c.lang3:

      This product bundles commons-lang3 3.1, which is available under a
      "Apache 2.0" license. For details, see LICENSE.
      
      This product bundles commons-lang3 3.10, which is available under a
      "Apache 2.0" license. For details, see LICENSE.
      
      This product bundles commons-lang3 3.12.0, which is available under a
      "Apache 2.0" license. For details, see LICENSE.
      
      This product bundles commons-lang3 3.4, which is available under a
      "Apache 2.0" license. For details, see LICENSE.
      
      This product bundles commons-lang3 3.5, which is available under a
      "Apache 2.0" license. For details, see LICENSE.
      

      We need to move the latest version of this library dependency to core and assemble in /lib.

      Then we can remove other dependencies in the various plugins

       

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              mcasters Matt Casters
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m